Revelation Natural Art Reference Guide

Copyright © 2002 Logotron Limited

Natural Art Reference Guide written by A. Blaho, I. Kalas, L. Salanci, P. Tomcsanyi & Logotron Limited

Published by Logotron Limited

Part number: REVELA01

All rights reserved

No part of this publication, either the whole or any part of the program or documentation, may be reproduced, transmitted, transcribed, stored in a retrieval system or translated into any language or computer language in any form or by any means, electronic, mechanical, optical, chemical, manual or otherwise, except as permitted under the licence agreement, without the express written permission of the publisher.

Edition 1
# Contents

1 Welcome to Revelation Natural Art

1.1 Overview ............................................................................................................................. 1
1.2 Elements of Natural Art .................................................................................................... 3
1.3 The tools that Natural Art provides .................................................................................. 4
1.4 Mouse or graphics pen with tablet .................................................................................... 5

2 Creating and organizing pictures

2.1 Creating new pictures ..................................................................................................... 10
2.2 Setting the paper properties .......................................................................................... 13
2.3 Basic commands: New, Open, Print and Save ............................................................... 14
2.4 Working with several pictures ......................................................................................... 15
2.5 The basics of configurations and customizations ......................................................... 17
2.6 How to exit Natural Art .................................................................................................. 19

3 Exploring the workspace

3.1 The main menu bar ......................................................................................................... 25
   File menu options ............................................................................................................. 25
   Edit menu options ........................................................................................................... 29
   View menu options .......................................................................................................... 33
   Paint menu options .......................................................................................................... 37
   Animation menu options ................................................................................................. 40
   Help menu options .......................................................................................................... 43

3.2 The page .......................................................................................................................... 44
   Creating a new sheet of paper ......................................................................................... 45
   Paper Properties dialogue box ....................................................................................... 47
   Transparent pixels ........................................................................................................... 49

3.3 Toolbars and tool windows ............................................................................................ 51
   The Main toolbar .......................................................................................................... 51
   The Shapes toolbar ........................................................................................................ 52
   The Painting and Effects toolbar ................................................................................... 53
   The Brushes toolbar ....................................................................................................... 54
## Contents

The Palette toolbar 55  
The Stamp Browser 56  
The Animation toolbar 57  
The Organizer 59  
The Colour Chooser 60  
The Zoom Settings tool window 60  
The Nibs toolbar 62  
The Colour Settings tool window 63  
The Status line 64

### 4 Working with a single picture .................................................................................................................. 67

#### 4.1 Choosing a brush ................................................................................................................................. 67

- Felt pen 68  
- Felt brush 69  
- Pencil 70  
- Watercolour 71  
- Colour tub 72  
- Cromar 73  
- Acrylic 74  
- Wax crayon 75  
- Oil pastel 76  
- Chalk 77  
- Charcoal 78  
- Spray 79

#### 4.2 Choosing colours and transparencies .................................................................................................... 80

- Colour Picker 81  
- Level of transparency: the Transparency slider 82  
- Colour models 83  
- Choose Colour dialogue box 84

#### 4.3 Setting a nib ............................................................................................................................................. 85

#### 4.4 Adding shapes .................................................................................................................................... 86

- Freehand drawing: solid and dotted 87  
- Line: single and rays 88  
- Ellipse or circle: outline and filled 90  
- Rectangle or square: outline and filled 91
Regular polygon: outline and filled ................................................................. 92
Star: outline and filled ..................................................................................... 93
Polygon: simple, closed and filled .................................................................. 94
Spline: simple, closed and filled ...................................................................... 96

4.5 Adding text .................................................................................................. 100
4.6 Undo and Redo mechanism ......................................................................... 103
4.7 Filling and replacing colours ......................................................................... 104
4.8 Working with motifs ..................................................................................... 105
4.9 Working with textures .................................................................................. 110

4.9 Adding stamps ............................................................................................ 113
   Simple use of stamps ...................................................................................... 115
   Drawing with a stamp ...................................................................................... 117
   A stamp as a selection ..................................................................................... 119
   Dragging a stamp with the right mouse button ............................................. 120
   Stamps with stacks of pictures ....................................................................... 121
   Stamps control menu ...................................................................................... 126
   Stamps and the graphics tablet ..................................................................... 128
   Adding your own stamps .............................................................................. 128

4.10 Applying painting effects ........................................................................ 129
   What are painting effects? .............................................................................. 129
   List of painting effects ................................................................................... 130
   Basic drawing .................................................................................................. 131
   Erasing ............................................................................................................. 132
   Colouring ......................................................................................................... 133
   Smearing .......................................................................................................... 134
   Lightening ........................................................................................................ 135
   Darkening ........................................................................................................ 135
   Softening ......................................................................................................... 136
   Sharpening ....................................................................................................... 137
   Highlighting edges .......................................................................................... 138

4.11 Anti-aliasing ............................................................................................... 139

4.12 Working with symmetry ........................................................................... 141
## Contents

4.13 Selecting items ............................................................................................................145  
  Selection mode 145  
  Selection menu 148  
4.14 Zooming ......................................................................................................................150  

5 Working with images: animations....................................................................................153  
  5.1 Images and their properties ...........................................................................................154  
    HotSpots 155  
    Delays 156  
    Heading mode or Frame mode 157  
    Zero angle 158  
    Animation loops 159  
    HotSpot dialogue box 159  
    Transform dialogue box 161  
    Generate dialogue box 163  
  5.2 The Organizer................................................................................................................166  
    Organizer window overview 166  
    Organizing images 168  
    Organizing frames 172  
    Organizing frame items 178  
  5.3 Preview mode................................................................................................................183  
    Positioning the image 184  
    Preview area menu 185  

6 Customizing Natural Art...................................................................................................187  
  6.1 Simple level...................................................................................................................189  
  6.2 Junior level ....................................................................................................................191  
  6.3 Advanced level..............................................................................................................193  
  6.4 Setting up your own configuration: Customize dialogue box.......................................194  
    Configurations 195  
    Commands 196  
    Components 198  
    Bars and Windows 200  
    Other 204
Contents

7 Glossary of basic terms and concepts ................................................................. 207
8 Table of keyboard shortcuts .................................................................................. 215
1 Welcome to Revelation Natural Art

1.1 Overview

Natural Art is a general-purpose graphics application specifically aimed at younger users. It provides them with a simple, intuitive and natural, yet powerful and comprehensive tool for art and design. It is suitable for a wide age range; from very young beginners, through juniors and home users to advanced users with a lot of experience, high expectations, and considerable expertise in both computers and art.

Natural Art is a powerful bitmap and animation editor. It lets you create or modify pictures that may be used as pieces of art for your gallery, printed decorations, pictures for your web pages or in many other ways. In addition, Natural Art provides you with the opportunity to create or modify stacks of pictures – animations to be used in your web pages as animated gifs, animated cursors for Windows or complex stamps for Natural Art itself.
Natural Art provides a wide range of artistic brushes and other tools for drawing and painting, writing text, inserting stamps or basic geometric shapes (like lines, circles, rectangles, ellipses, polygons or splines), filling with colour or a selected motif etc. It can also be used to develop or modify standard Windows icons and cursors, and it works with the standard Windows Clipboard. Natural Art makes it possible to resize, rotate, skew, distort and colour images. It also provides powerful tools for generating and/or transforming animations or animated films, i.e. sequences of frame items. It supports many other advanced graphics operations and recognizes (both for opening and saving) most frequently used file formats.

Amongst other exciting features and properties, Natural Art offers a wide range of customization opportunities. You have control over the entire screen structure, you can choose or develop your own configuration. You are encouraged to create your own toolbars and tool windows, hide tools that you are not currently using, reduce menu options, create your own tool windows and define your own shortcuts.
1.2 Elements of Natural Art

When creating your pictures initially, the following diagram may help you find all of the groups of tools and options provided by Natural Art. You should soon learn how to use most of them and how to get the most out of the product because Natural Art provides its tools and features in a very intuitive way.
1.3 The tools that Natural Art provides

Natural Art is a new generation of Graphics editor. It offers you exciting tools such as:

• A wide range of artistic brushes for creating natural looking paintings.
• Convenient and alternative ways of selecting the colour you need.

• A natural and intuitive interface making use of both the mouse and a pressure-sensitive graphics tablet with pen.
• A Stamp Browser which makes it possible to add simple or complex stamps to your pictures.
• Several symmetry modes.
• Motifs, as an alternative to simple colours, for filling regions.
• A wide range of painting effects.
• Strong support for developing or modifying stacks of pictures, i.e. animations.
• Transformations that can be applied to simple or multi-frame pictures.
• An interactive tool for organizing pictures, their frames and frame items.
• An exceptionally wide range of ways of customizing the environment.
• Compatibility with Imagine - the Logo language environment also published by Logotron Limited.
1.4 Mouse or graphics pen with tablet

You can use and interact with Natural Art either by using the mouse or a graphics tablet with pen (either as a stand-alone input device or as an integrated part of a tablet PC). Although using the mouse is sufficient to fully interact with Natural Art, your pictures may look even more natural if you use the graphics pen. The reason is that several of the brushes available in Natural Art are sensitive to the pressure applied to the pen – this means that you can obtain strokes of continuously varying thickness and density. Therefore, it is recommended that you attach a pressure-sensitive graphics tablet with pen to your computer to get the most from Natural Art.

Note that there are many brands of graphics tablets. Any of these can be used, provided that its pen is sensitive to varying pressure. (Before starting to use a graphics tablet and a pen with Natural Art, make sure that it is properly installed and set.) Most brands of graphics sets consist of two or three basic items – a graphics tablet, a pen and a cordless mouse. The tablet usually consists of a pen stand, a status LED and an active area with overlay. The pen itself is a pressure-sensitive freehand tool for drawing, painting and controlling the whole application. It consists of a pen tip (the pointer), a button (or switch) and an eraser on the reverse end of the pen. You can use the pen – in a similar manner to a mouse – for pointing, clicking, double-clicking, dragging and alternative clicking (i.e. clicking with the right mouse button).
You hold the graphics pen like a normal pen in a suitable position so that you can draw with it on the tablet's active area. Note that the pen is activated as soon as it is just above the tablet's active area. This allows you to position the cursor without touching the pen tip to the tablet. Usually, the pen starts to be registered when it is 5 mm or less above the tablet.

The cordless mouse, which is often another component of the set, can be used for controlling the application and for navigation, often via a programmable middle button and a mouse wheel.

The following describes how to perform certain operations (note that some of the following functions can be customized or reset in the tablet control panel):

- **Pointing.** You can use the pen to position the pointer (cursor) on your screen. The active area of the tablet corresponds to your computer screen. Whenever you place the pen on the tablet, the cursor moves to the corresponding point on the screen. You can move the Natural Art cursor by lifting the pen and placing it in a new location on the tablet. The cursor jumps to the new location.

- **Clicking.** To click with the pen, either tap the tablet with the tip of the pen, or press the pen tip on the tablet with enough force for a click to be recognized.

- **Double clicking.** Tap the tablet twice in the same place with the pen tip.

- **Using the button.** It usually has programmable functions (one or two) that can be selected in the tablet control panel. You can use the button whenever the pen tip is close to the table. That is, you should not touch the pen tip to the tablet in order to use the switch. Usually the switch is set to correspond to a click with the right mouse button.

- **Dragging.** Use it to select and move objects on the screen. First point to an object, then press the pen to the tablet and slide it across the tablet.
• **Drawing with pressure.** The pen responds to the pressure of your hand, enabling you to create natural-looking brush strokes in Natural Art. This means that you can vary line *thickness* and/or colour *density*. To use pressure-sensitivity, select a *brush* and drag it along the surface of the tablet whilst applying varying pressure downwards on the tip of the pen. Press hard for thick or dense lines, press gently for thin or light lines.

• **Erasing.** The eraser on the pen (i.e. its reverse end) works like the eraser on a pencil. Thus, you can *erase* intuitively and naturally. Note, however, that you can also erase by dragging the mouse cursor along your picture with the right mouse button, or by dragging the pen with its button pressed. Note also, that when you finish erasing in this way, all previous settings are restored (like the currently selected brush, its nib size, colour, transparency etc.) – which is not true when you finish erasing with the *erasing tool*.
2 Creating and organizing pictures

This chapter gives you a short introductory tour around Natural Art, its environment and all the tools that appear in the Advanced interface. You will go through a simplified **work cycle** with Natural Art, from starting with an empty page through selecting colours and tools, applying effects, undoing and redoing, cutting, copying and pasting, adding shapes, text and stamps… to printing your picture, saving it and loading it back. You will discover how to handle several pictures, both simple pictures and stacks of pictures – animated sequences. You will learn how to switch to another configuration and how to modify the environment of Natural Art to fit your personal needs. This short tour will cover:

- Creating new pictures
- Setting the paper properties
- Basic commands: New, Open, Save And Print
- Working with several pictures
- The basics of configurations and customizations
- How to exit Natural Art

You will learn about the details, features and more advanced techniques later. To do so, experiment on your own and see the following sections:

- Exploring the workspace
- Working with a single picture
- Working with images: animations
- Customizing Natural Art
- Table of keyboard shortcuts
2.1 Creating new pictures

When you start Natural Art, you can see its powerful environment, which provides several toolbars and tool windows. It will probably look similar to the following:

Try the following:

- **Familiarize yourself with the environment and try to produce your first scribble in Natural Art.** Look for the vertical toolbar containing the icons of the twelve different **artistic brushes**. Click on them one by one and scribble on the paper. Try the following useful keyboard shortcuts:
  - **F5** shows or hides a bar containing a set of the selected type of brush in several colours.
  - **F7** shows or hides a palette of colours at the bottom of the window.
  - **F8** shows or hides the **Zoom** window.
• Experiment with the basic tools. Try to draw with the mouse and with a pressure-sensitive graphics tablet if available. You should quickly discover that by changing the pressure on the graphics pen you can obtain lines of varying thickness and density.

• Click on the grey minimized title bar of any toolbar or tool window and drag it – this makes the toolbar or tool window float rather than being docked to the window. Re-organize the screen how you would like it. Leave the toolbars or tool windows floating or dock them on the opposite edge of the window. (In Customizing Natural Art you learn how to turn a horizontal toolbar into a vertical toolbar and back again.)

• Experiment with different brushes and different colours. Note that you can use the Palette to slightly mix the current colour with any other in the palette.

• Find the Nibs toolbar and experiment with different nib sizes. Note that for several brushes, when you apply one long stroke, the colour slowly dries out and fades. If you stop the stroke and start again, it is as if you dipped the brush into the colour again – the trace will be dense again.
Creating and organizing pictures

- Click on the buttons in the **Shapes** toolbar to add rectangles, circles, polygons etc.
- Click on the **Text** button and type a short message into the **Text** window. Select any font, colour, size and style and drag the text frame to any position. Then click outside it to add the text into your picture.
- Press **Alt+F7** to open the **Colour Chooser** and experiment with different levels of **colour transparency**.
- Choose the **View->Stamp Browser** option to show or hide the **Stamp Browser**. Find a stamp you like, click on it, then click on the paper. Or try to draw with the cursor within the paper.
2.2 Setting the paper properties

To set the paper properties:

1. Choose the View->Paper Properties... option or click on the Paper Properties button on the Main toolbar.

   The Paper Properties dialogue box opens.

   Here you can reset the size of the paper you are working with. You can either choose one of the standard sizes or you can specify your own size in pixels. You can also specify the background colour of the paper (and also its background picture). This is sometimes very useful, because you can, for example, erase parts of the picture, thus partly restoring the original paper colour.

   In the picture below, we specified a light paper background colour, then painted with oil pastels and rays of lines upon a texture). Then we applied the eraser to add the partly transparent filled circle. Thus we created a place where we can, for example, add text.
2.3 Basic commands: New, Open, Print and Save

To save your picture:

1. Go into the **File** menu and choose the **File->Save As...** option.
2. Enter a name for your picture and save it.
   
   You may choose one of several **recognized file formats** depending on how you want to use the picture later. The default format is a native Revelation Natural Art RNA image file.

Later you can continue working on your picture:

1. Start Natural Art again and choose the **File->Open...** option.
   
   This allows you to open your own pictures or to import photographs or pictures downloaded from the Internet etc. These can be bitmaps, gifs, Imagine images or one of many other supported file formats.

To start afresh:

1. Choose the **File->New** option.

Note that after choosing this option, a new sheet of paper appears in the main window of Natural Art. Its size and background colour are identical to the values most recently set in the **Paper Properties** dialogue box or, if you have not visited that dialogue box yet, they match the default settings, which include a white background colour.

You can print your picture at any time:

1. Choose the **File->Print...** option to open the **Print** dialogue box.
2. Go into **Print Setup...** if you want to change the paper orientation from **Portrait** to **Landscape**.
3. Tick the **Expand to page** option if you want your picture to cover the whole sheet of paper.
2.4 Working with several pictures

Sometimes it is useful to work on several pictures in parallel. This allows you to copy things from one picture to another, process several pictures in the same way, compare them, combine them together etc. In Natural Art you can repeatedly choose the File->Open... option. You can bring other pictures or screen shots in through the Clipboard. You can also choose the File->New option several times and thus create several new pictures.

As soon as you start working on several pictures in parallel, you have to organize them:

1. Press **F4** to open a special tool to help you with this – the **Organizer** window.

   In this window there is a tab for each picture you have open in Natural Art.

   ![Organizer window](image)

2. Click on the tab of the picture you want to work on.

3. Click on the **Selection** button of the **Main** toolbar to **select** part of one picture.

4. Press **Ctrl+C** to copy the selection into the Clipboard.

5. Then go to another picture and press **Ctrl+V** to paste the selection there.

Note that the tabs of the **Organizer** have the names of the pictures on them. If the picture is of a native Revelation Natural Art file format (i.e. an **RNA**), the format extension is not shown. Otherwise the format of the picture is given, together with its name, for example **Julles.gif** or **roof.bmp**. Note also that if you create a new picture within Natural Art, its temporary name will be **Image 1**, **Image 2** ... etc. until you give it a name by choosing **File->Save As...**
Creating and organizing pictures

All the pictures that you have worked with so far have been simple pictures. However, Natural Art is also an excellent tool for creating or modifying **stacks of pictures**. Usually, these are animated pieces of graphics like animated gifs, imagine **images** to be used as the shapes of Logo turtles, animated cursors for Windows or complex **stamps** for Natural Art itself. These complex images usually consist of several **frames**. Each frame consists of either a single picture or a stack of pictures called **frame items**. A stack of pictures forms a kind of animation film that illustrates, for example, the movement of a certain character in a certain direction. In this scenario, different frames may illustrate the movement of a particular character in different directions (like **walking to the right, walking towards us, walking to the left** and **walking away from us**).

Open one or several **RNA, LGF, GIF or ANI** files. The **Organizer** window can, once again, help you to organize these complex images. You may want to insert new frame items, move them from one frame to another, apply complex **transformations** to several images in a single step etc. This would not be possible without this powerful tool.
2.5 The basics of configurations and customizations

Natural Art is a kind of building set made up of hundreds of small pieces called components. Therefore, it is extremely suitable for being customized. Whatever you are using it for, you may rebuild the whole environment so that it fits your current work better:

1. Choose the View->Other->Customize... option or press Ctrl+Alt+Space to open the Customize window.

2. Make sure that its first tab, Configurations, is displayed.
   This presents you with a set of predefined configurations – suitable for beginners, junior users and advanced users.

3. Click on any of these and then click on the Use button.
   This is also where you can switch to other predefined customizations in Natural Art.

To customize your own toolbar:

1. Click on the Bars and Windows tab of the Customization window and click on the New Toolbar button.

2. A new, empty toolbar is created. Make sure that you can see it.

3. Click on the Properties button and specify the title.

4. Click on Vertical and then close the Toolbar Properties dialogue box by clicking on the OK button.

5. Open the Components tab of the Customization window and start to fill it with the buttons and brushes of your choice.

   For example, go to the Paint group and its Brush Preset subgroup. Find Pencil, specify its colour and nib size, and then drag its icon on top of your new toolbar. Repeat this for other colours or sizes or brush presets. Then go to the View group and add some buttons to open other useful toolbars.
6. Then, either just close the Customize window or save your customization as your own user-defined configuration, thus making it available for future use.

Within your configuration you can specify your own shortcuts, hide tools that are currently not relevant to you, hide all menu options that you do not need for your current task, create other toolbars and tool windows and reorganize the whole screen.

You can create as many user-defined configurations as you find useful.
2.6 How to exit Natural Art

Be careful not to leave Natural Art without saving your work. To exit Natural Art, you can:

- Choose the **File->Exit** option or press **Alt+X** or **Alt+F4** or click on the **Close** button of the Natural Art main window. In each of these cases, Natural Art prompts you to save any unsaved pictures. Natural Art then exits.

- If you are working with several pictures and you want to close just the one that is currently displayed on the paper, choose the **File->Close** option or press **Ctrl+F4**. If the picture contains any unsaved changes, Natural Art prompts you to save the image before closing it. The application itself does not exit. An alternative method of doing this is to right click on the tab of the picture in the **Organizer** and choose the **Close** option from the menu that opens.

- To close several successive pictures in one go without closing Natural Art itself, select them by clicking multiple tabs in the **Organizer** with the **Shift** key pressed, then press **Ctrl+F4** or right click on the selected tabs and choose **Close**.
3 Exploring the workspace

If you are already an experienced user of other bitmap editors you will most probably use Natural Art in its advanced level so that you can make full use of its power and features. (If this is not the case, you may be interested to learn about the simple level and junior level of Natural Art.) If you start Natural Art in its advanced level environment you will see the following key items (some of them may be hidden or minimized):

- The main menu bar
- The page
- Toolbars and tool windows

The more you use Natural Art the more efficient you will become in customizing the environment. Natural Art is surprisingly open and flexible in the extent to which you can arrange and modify all its components within the screen and thus create a more suitable and focused environment for your needs. Overleaf is one possible arrangement that is suitable for processing photographs (with several toolbars hidden and some others minimized).
Exploring the workspace

If a toolbar or a tool window is completely hidden, you can make it visible by:

- Choosing the **View->Bars and Windows** option, then selecting its name from the list, or
- Pressing the corresponding shortcut, if it exists (for example, **F4** for the Organizer, **F8** for the Zoom window etc.).

By repeating this, you hide the toolbar or tool window again. If it is currently floating (see below), you can also hide it by clicking on the small **x mark** in its title bar. If a toolbar or tool window is floating, it may contain a small **triangle mark** in its title bar. By clicking on it, you can minimize/show the toolbar or tool window.

Each toolbar or tool window is defined to be of either **horizontal type** or **vertical type**. If a toolbar or tool window is of horizontal type, you can dock it to either the top or bottom edge of the Natural Art main window or to any other toolbar or tool window already docked there. If it is of a vertical type, you can dock it to either the left or right edge or to any other toolbar or tool window already docked there.
To make a docked toolbar or tool window float, click on its title bar and drag it. To dock it back, drag the toolbar or tool window by its title bar until it hits the edge of the main window.
Exploring the workspace

If you make all the standard toolbars and tool windows of Natural Art (advanced level) visible and undocked, you will see the following collection of tools and components:
3.1 The main menu bar

This is a bar at the top of the screen that contains the **File**, **Edit**, **View**, **Paint**, **Animation** and **Help** menus. Each of these displays a list of options that are described further below. Some of these options have small icons next to them. These correspond to icons on the main toolbar or the **Painting** toolbar or one of the other available toolbars and are displayed to help you associate the option with the corresponding button.

**File menu options**

![File menu options](image)

**New**  **Ctrl+N**  Creates a new empty sheet of paper (i.e. an **image** with one **frame** consisting of one **frame item**). Its width, height and background colour are identical to the most recently specified values of these settings in the **Paper Properties** dialogue box.
Exploring the workspace

Open… Ctrl+O Displays the Open dialogue box with the Preview window. The folder displayed in the dialogue box is either the My Painting folder of Natural Art or the folder most recently used for the Open option.

In the Open dialogue box you can select and open any picture (or several pictures, if you select several files) of any supported file format.

Save Ctrl+S Saves the currently selected image (with all its frames and frame items) into a file of any supported file format. When you save an image for the first time, the Save As dialogue box opens so that you can name your image.

If you want to change the file's name, format or the destination where it is saved, you must choose the Save As… option.

Save As… Alt+F2 Saves the image currently selected and displayed under a new name, in a different format and/or at a new location. If you want to save the file with its existing name, format and location, you can use the Save option instead.

Close Ctrl+F4 Closes the image without exiting the application. If the image contains any unsaved changes, Natural Art prompts you to save the image before closing.
Exploring the workspace

**Print** Ctrl+P  
Displays the **Print** dialogue box which contains **Range**, **Layout** and **Preview** areas, plus the standard **Print Setup…**, **Cancel** and **Print** buttons.

The **Range** area options allow you to decide whether you want to print only the selected **frame item(s)** or all frame items of the image.

The **Layout** area tick boxes allow you to decide whether you want to print the numbers of the frame items, whether you want to put all the frame items into one line and whether you want to proportionally resize the printed picture so that it covers the whole page, if possible.

![Print dialogue box](image)

The **Preview** area gives you an idea of how the printed page will look. Experiment with different combinations of **Range** and **Layout** options together with the **Print Setup…** button and dialogue box.
For example:

Note that the **paper background colour** and **paper background picture** are printed as well.

<File names>

The group of file names between then **Print** and **Exit** options are the files most recently opened in Natural Art.

**Exit**  **Alt+X**  Closes all images after prompting you to save any unsaved ones.
Edit menu options

**Undo <last change>**  
Ctrl+Z  
Applies one undo step of the *undo and redo mechanism*.

**Redo <last change>**  
Shift+Ctrl+Z  
Applies one redo step of the *undo and redo mechanism*.

**Cut**  
Ctrl+X  
Removes the currently selected object; i.e. removes either (depending on the activity):

- The **selected** part of the picture, or
- One **frame** or several frames, or
- One **frame item** or several frame items

and puts it/them into the Clipboard.
The **Cut** option is not available if several **images** are selected in the **Organizer**: 

![Organizer](image)

If you are currently working with the whole image, i.e. one of the images is selected in the **Organizer** and you choose **Cut**, one of its frame items will be cut instead of the whole image (which frame item it is will depend on what you have been working with recently).

<table>
<thead>
<tr>
<th>Copy</th>
<th>Ctrl+C</th>
</tr>
</thead>
<tbody>
<tr>
<td>Makes a copy of either a whole <strong>image</strong> (or several images), a <strong>frame</strong> (or several frames) or a <strong>frame item</strong> (or several frame items) and puts it/them into the Clipboard.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Paste</th>
<th>Ctrl+V</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you have cut or copied a <strong>selected</strong> part of a picture, <strong>Paste</strong> inserts a copy of the Clipboard contents as a patch into your picture.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Paste Before</th>
<th>Ctrl+V</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you have cut or copied one or several <strong>frames</strong> or one or several <strong>frame items</strong> into the Clipboard, the <strong>Paste</strong> option of the <strong>Edit</strong> menu is replaced by a pair of options; <strong>Paste Before</strong> and <strong>Paste After</strong>. They insert a copy of the Clipboard contents either:</td>
<td></td>
</tr>
</tbody>
</table>

- Before/after the current frame, if you have cut or copied a frame or frames.

- Before/after the current frame item, if you have cut or copied a frame item or frame items. |
If you want to cut or copy a frame and paste it somewhere as a frame item, you have to cut or copy it, then paste it into its new position via the corresponding organizer menu (i.e. through the Frame Item Organizer menu). Similarly, you can use other organizer menus to paste frame items as images or frames etc.

**Insert Before**

Inserts a new frame before the current frame, if you have been working with a frame. Inserts a new frame item before the current frame item, if you have been working with a frame item.

The newly inserted frame or frame item has an identical size and background settings to the frame or frame item it is inserted before.

**Insert After**

Inserts a new frame after the current frame, if you have been working with a frame. Inserts a new frame item after the current frame item, if you have been working with a frame item.

The newly inserted frame or frame item has identical size and background settings to the frame or frame item it is inserted after.

**Delete**

Deletes the current element, it may be a frame (or several frames), a frame item (or several frame items) or a selected part of your picture.
Select All   Ctrl+A

Selects all **images**, if you are currently working with images. Selects all **frames**, if you are currently working with frames. Selects all **frame items**, if you are currently working with frame items.

Selects the whole picture, if you have currently been drawing, painting or working within the picture.
View menu options

- **Brushes** F5 Opens or hides the **Brushes** toolbar.
- **Organizer** F4 Opens or hides the **Organizer** window.
- **Palette** F7 Opens or hides the **Palette** toolbar.
- **Stamp Browser**
- **Zoom Settings** F8 Opens or hides the **Zoom Settings** window.
Exploring the workspace

**Other**

Opens a submenu containing a list of additional toolbars and tool windows available in the current **configuration**. Select the toolbar or tool window that you want to be displayed. Clear the toolbar or tool window that you want to hide.

![Customize dialogue box](image)

**Customize**… opens the **Customize** dialogue box. Choose this option to set another configuration or customize the environment.

**Colour Model**

Opens a submenu containing three different **colour models**. Allows you to select which one will be used in the **Colour Chooser**, the **Choose Colour** dialogue box and the **Preview Background Colour Chooser**.

**Onion Skin**

Opens a submenu in which you can specify what you want to see behind the currently displayed **frame item**; either the previous frame item, two previous pictures (frame items) or the next picture (frame item). To switch this mode on and off (according to the currently selected type of onion skin), click on the **Onion Skin** button of the **Main** toolbar.

Note that these 'ghost' pictures are not part of the picture displayed. They provide a background to help you when drawing, painting or **creating the animation**.
If the **Onion skin** mode is on and you turn the **Show and Specify HotSpot** mode on as well, the ghost pictures are tied to the **HotSpot** cross and will move with it.

This picture has two frame items. In the first one you can use regular shapes to construct your picture or its skeleton. In the second one – with the Display Previous Picture option on – you can use it as a kind of stencil.

**Zoom**

- **Ctrl+Q**
- **Ctrl+W**

Opens a submenu containing two groups of settings. In the first group you can zoom in to the picture, restore the **Normal Size** (i.e. 100% size), or zoom out.

If you click on the **Zoom In** option, the zoom factor is increased by one step. If you click on the **Zoom Out** option, the zoom factor is decreased by one step. Key combinations can be used instead: **Ctrl W** or **Ctrl Num +** zoom the picture in one step, **Ctrl Q** or **Ctrl Num –** zoom the picture out one step and **Ctrl Num *** returns the picture to 100%.

**Grid**

If you tick this option, a grid of lines is displayed (providing that you are zoomed in to 400% or more). These lines help you to paint, draw and navigate in the zoomed picture.
Exploring the workspace

**Transparent Pixels**

If you tick this option, all transparent pixels of the picture are highlighted by a black dot in the middle of the zoomed point (providing that you are zoomed in to 400% or more). Do not confuse the transparent pixels with *partly transparent colours*.

---

**Show and Specify HotSpot**

Displays the current position of the **HotSpot** and changes the mouse cursor into a white cross. This cursor illustrates that you are going to change the position of a HotSpot. For further details see the description of the **HotSpot** dialogue box.

---

**Paper Properties...**

Opens the **Paper Properties** dialogue box.

---

**Preview F9**

Toggles **Preview** mode on/off.
Paint menu options
Anti-aliasing

This option (and also the corresponding button on the Main toolbar) toggles the anti-aliasing mechanism on/off. Anti-aliasing makes the edges of shapes and letters appear smooth by adding extra pixels in various levels of transparency of the currently selected colour.

Symmetry

Opens a submenu containing four options for symmetry. Select either None or one of three alternative strategies for symmetrical drawing, painting, stamping and printing text.

Note also the corresponding buttons on the Main toolbar together with the Symmetry Setup button.

Nib

Opens a submenu which makes it possible to set a nib size and, when applying a painting effect, a nib shape. For further details see the description of the Nibs toolbar.

Brush

Opens a submenu containing all the available brushes. The last option opens another submenu containing all the available painting effects.

Shape

Opens a submenu containing options for:

- Adding shapes
- Filling and replacing colours.
- Adding text.

Note that most of these options open a further submenu with related options. For example, the Rectangle option offers two further options: Outline and Filled.
<table>
<thead>
<tr>
<th><strong>Stamp</strong></th>
<th>Opens the <strong>Stamps</strong> control submenu.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Selection</strong></td>
<td>Opens the <strong>Selection</strong> submenu.</td>
</tr>
<tr>
<td><strong>Clear Picture</strong></td>
<td>Clears the whole picture by covering it completely by transparent pixels of the current paper's background colour and restoring its background picture (if specified). If the picture consists of several <strong>frames</strong> with several <strong>frame items</strong>, only the currently displayed frame item will be cleared.</td>
</tr>
</tbody>
</table>
Animation menu options

Frames

Opens a submenu that allows you to:

• Turn the animation loop of the image on or off.
• Turn the Heading mode of the image on or off.
• Specify the zero angle of the image.
• Transform all the frame items of all the frames into one frame with all the frame items linked together.

The same settings (and also others) can be applied via the right mouse button menu in the Frame Organizer.

Frame Items

Opens a submenu that does the opposite to the Convert All to Frame Items option. It transforms all the frame items currently displayed in the Frame Item Organizer into separate frames.
Set Delay… Ctrl+D

Allows you to specify **time delays** for all the currently selected **frame items** or **frames** or even whole **images**. It opens the following dialogue box:

Note that in this dialogue box you can either specify an exact number for all selected frame items, or a percentage such as 80% to increase or decrease the previous delays whilst preserving their proportions.

Set HotSpot… Ctrl+H

Opens the **HotSpot** dialogue box to allow you to specify a **HotSpot** for all the selected frame items.

Minimize Ctrl+M

Reduces the currently selected **frame item** (or several items) or **frame** (or several frames) or even whole **images** by removing all outside columns and rows that contain only **transparent pixels**. Note that this operation does not spoil the relationship between the picture and its **HotSpot**.

Note that there is a corresponding button on the **Animation** toolbar.
### Exploring the workspace

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Blend</strong></td>
<td><strong>Ctrl+B</strong></td>
<td>Inserts a transition (a kind of visual average) between each pair of successive selected frame items of a frame, or between each pair of successive frame items of all selected frames.</td>
</tr>
<tr>
<td><strong>Generate</strong></td>
<td><strong>Alt+G</strong></td>
<td>Opens the Generate dialogue box.</td>
</tr>
<tr>
<td><strong>Reverse Order</strong></td>
<td><strong>Ctrl+R</strong></td>
<td>Reverses the order of all the selected frame items or all the frame items in all the selected frames or whole images.</td>
</tr>
<tr>
<td><strong>Transform</strong></td>
<td><strong>Alt+T</strong></td>
<td>Opens the Transform dialogue box.</td>
</tr>
</tbody>
</table>
## Help menu options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help Topics</td>
<td>Opens the Contents tab of the online help.</td>
</tr>
<tr>
<td>Natural Art F1</td>
<td>Opens the page of the online help corresponding to what you are currently doing.</td>
</tr>
<tr>
<td>Go to Latest Info…</td>
<td>Opens a web site containing current information about the Natural Art editor.</td>
</tr>
<tr>
<td>About…</td>
<td>Opens the Natural Art About dialogue box containing details of the editor.</td>
</tr>
</tbody>
</table>
3.2 The page

The central part of the Natural Art main window is covered by either:

- The **page with the picture** you are currently working with (either a single picture or one of the **frame items** of a **stack of pictures**). The picture displayed may either be zoomed in or zoomed out or at its normal size, or

- A **preview** of the picture you are currently working with.

To swap between the paper view and preview, you can either:

- Press the **F9** function key, or

- Choose the **View->Preview** option, or

- Press the **Play Forward** button or the **Play Backward** button of the **Animation** toolbar.

The left part of the figure shows a zoomed in paper view of a single picture, the right part shows the same picture in **Preview** mode.
Each sheet of paper has the following settings:

- **Size**, i.e. its *width* and *height*.
- **Background colour**.
- **Background picture**.

Note that, in addition to these settings, you may also specify the *texture of the paper* to be used when you paint or add shapes etc. However, you can change the texture of the paper at any time, thus it is more a feature of painting or adding elements rather than a feature of the paper itself.

### Creating a new sheet of paper

You can create a new sheet of paper for a completely new picture. To do this:

1. Choose the **File->New** option.

The new sheet of paper's width, height and background colour are identical to the most recently specified values of these settings in the **Paper Properties** dialogue box. The paper is covered by **transparent pixels** (with the paper's background colour lying behind them).

You can insert a new sheet of paper into an existing picture if the picture is an *image*, i.e. a stack of pictures like an animated GIF or Imagine image with animation, animated cursor etc. To do so:

1. Either:
   - Choose the **Edit->Insert Before** or **Edit->Insert After** option, or
   - Right click on a frame item and choose the **Edit->Insert Before** or **Edit->Insert After** option in the **Frame Item Organizer** menu; or
   - Right click on a frame and choose the **Edit->Insert Before** or **Edit->Insert After** option in the **Frame Organizer** menu.
With each of these alternatives, the new sheet of paper's width, height and background colour are identical to the adjacent frame item. The paper is covered by transparent pixels (with the paper's background colour lying behind them).

You can paste a sheet of paper previously cut or copied into the Clipboard at any position, either as a patch into another page or as a new picture or as a single frame with one new frame item or as a new frame item between other frame items. To do this:

- Use the Edit->Paste Before and Edit->Paste After options from the main menu or Image Organizer menu or Frame Organizer menu or Frame Item Organizer menu.

The new (pasted) paper always preserves its size, background colour and picture.
Paper Properties dialogue box

To modify the settings of a sheet of paper:

1. Choose the View->Paper Properties… option.

The Paper Properties dialogue box opens. This shows the current paper settings, namely, its style, width and height, background colour and background picture.

All of these settings can be modified at any time and the original contents of your picture are preserved, unless the size is set to a value that is smaller than the picture's current width or height.
Exploring the workspace

Style

To select a style:

1. From the drop down menu either choose one of the predefined styles (e.g. A4 Landscape or A6 Portrait or Imagine Page etc.) or one of your own styles that you have defined earlier.

Note that selecting a style means specifying the paper's width, height, background colour and optionally the background picture.

You can save any paper setting. To do so:

1. Click on the plus sign to the right of the Style setting.
2. Enter a name for your current setting.

Thus, you can create your own paper styles. Note, however, that the background picture is not included in the paper style.

To delete a style:

1. Select the style and click on the cross sign to the right of the plus sign.

Colour

Paper Colour displays the current setting of the background colour. Note that this colour is not a part of the picture. The default value is white, as previewed in the large rectangular area next to the Colour caption of the dialogue box.

To change the background colour:

1. Click on the large rectangle next to the Colour caption.

The Choose Colour dialogue box opens and allows you to select another colour.
Background picture

In the Layout rectangle you can see the preview of the paper's background picture. The default value is None.

To select a picture:

1. Click on the preview area.
   A standard Open dialogue box opens and allows you to select a picture.

2. From the drop down menu to the right of the Layout preview select either:
   • None for no background picture, or
   • A strategy (Centre, Fit, Resize and Tile) specifying how the background picture should be placed on the background.

Experiment with these options. Note, however, that once you set a picture as a background picture of a paper using a certain strategy, it is applied immediately but Natural Art does not remember that particular strategy for future use. Thus, you can reset it later, but you cannot find the current strategy in this dialogue box.

Note also that the paper's background picture is not part of your picture. Thus, if you erase parts of your painting, the paper's background picture will be restored at the corresponding locations.

Transparent pixels

When you start creating a picture in Natural Art, all the pixels within the page are transparent by default. To verify this:

1. Set the zoom factor for the picture to at least 400%.
2. Tick the Transparent Pixels option of the Zoom Settings window.

All of the transparent pixels are then displayed with a dot at their centre (the dot is for display only – it does not appear on the screen later).
When you add colour to the picture, you are changing the pixels from being completely transparent to being coloured (possibly with a certain level of transparency). However, you can change them back again. To add transparent pixels to a picture, you can either:

- **Erase the colour**, or
- Use any combination of shapes, nibs and tools and paint or draw or add shapes etc. with the right button (of the mouse or pen) pressed.

Drawing in Natural Art with a partly transparent colour means that, to a certain extent, you can see through a colour to the colour beneath it. Note also that information about transparent pixels and levels of transparency of colours is not saved and preserved in all supported file formats. For example, if you save a picture as a BMP bitmap, all the transparent pixels will be replaced by pixels of the current background colour and all the partly transparent colours will be replaced by similar shades of colours without any transparency. Thus, the picture, when used as a bitmap, will look the same. But when you open it in Natural Art all the information about transparencies will have been lost.

The file formats that preserve the information about transparency correctly are RNA, LGF, DIB and TGA. To a certain extent it is also preserved in ANI, CUR, ICO, GIF and PNG.
3.3 Toolbars and tool windows

Toolbars and tool windows provide a short cut to most of the operations. Each of the operations covered can be chosen by at least one other different route, mostly through menu options or by keyboard shortcuts. Below, are illustrations of all the toolbars and tool windows within the advanced interface of Natural Art. To show them in the most illustrative way, each of these components is displayed floating (i.e. not docked), so that you can see its title bar. In addition, both the usual state of the toolbar or tool window, and also its customization state (when all buttons and other components are highlighted) are displayed, so that you can easily remember their shapes.

The Main toolbar

This contains buttons for:

- **Opening a picture, saving a picture** and **printing a picture**. They correspond to the File->Open…, File->Save and File->Print… options.
- Clearing a picture. This button corresponds to the Paint->Clear Picture option.
- Setting paper properties. This button corresponds to the View->Paper Properties… option.
- Cutting, copying and pasting the object you are currently working with. It may be a frame, a frame item or a selection. These buttons correspond to the Edit->Cut, Edit->Copy and Edit->Paste options.
- **Picking a colour** and the level of transparency from the picture. For more details, see the section on Choosing colours and transparencies.
- Undo and redo. These buttons correspond to the Edit->Undo <last change> and Edit->Redo <last change> options.
• **Anti-aliasing** on and off.

• Setting a texture. For more details, see the section on **Working with texture**.

• Setting a motif. For more details, see the section on **Working with motifs**.

• Setting a symmetry, namely horizontal and vertical symmetry, horizontal symmetry, vertical symmetry and symmetry setup. For more details, see the section on **Working with symmetry**.

• Show/hide the **Stamp Browser**. This button corresponds to the View->Stamp Browser option.

• **Selection**. This is the same as the Paint->Selection->Define Selection option.

• Toggle between the current zoomed view (either zoomed in or zoomed out) and normal view (100% size). For more details, see the description of the Zoom Settings window.

• Onion skin on and off. For more details, see the description of the View->Onion Skin option.

**The Shapes toolbar**

This consists of buttons for adding shapes (dotted freehand drawing, solid freehand drawing, single line, ray of lines, outline of an ellipse/circle, filled ellipse/circle, outline of a rectangle/square, filled rectangle/square, outline of a regular polygon, filled regular polygon, outline of a star, filled star, plain spline, closed spline, filled spline, plain polygon, closed polygon, filled polygon), for filling and replacing colours, for adding text and for setting the nib size.
For complete information, see the sections on:

- **Adding shapes**
- **Filling and replacing colours**
- **Adding text**
- **The Nibs toolbar**

### The Painting and Effects toolbar

This consists of two parts. The upper part lists all the types of available brushes (felt pen, felt brush, pencil, watercolour, colour tub, cromar, acrylic, wax crayon, oil pastel, chalk, charcoal and spray), the lower part lists all the available painting effects (basic drawing, erasing, colouring, smearing, lightening, darkening, softening, sharpening and highlighting edges).

For complete information, see the sections on:

- **Choosing a brush**
- **Applying painting effects**
Exploring the workspace

The Brushes toolbar

The current contents of this toolbar depend on the currently selected brush, for more details see the section on Choosing colours and transparencies. If you select a type of brush, the Brushes toolbar displays a set of identical tools in the most typical, available and natural set of colours.

To select a brush, either:

• Repeatedly click on the small grey arrows (left or right) at the top of the toolbar to browse through all the types of brushes, or

• Click on the grey brush between the two arrows to open a menu that contains the list of all available brushes.

Note that whenever you choose another type of brush, the Palette toolbar displays a different set of colours corresponding to the most usual colours for that particular brush.
The Palette toolbar

This is displayed in the lower left part of the main window. Its current contents depend on the currently selected brush (the right-hand picture below shows four different floating palettes for pencil, watercolour, wax crayon and charcoal).

Note that you can use the colours of the Palette toolbar in two ways:

- If you have selected a colour before, now you can adjust it slightly by dipping the brush into any colour of the palette and stirring. The longer you stir, the greater the amount of colour that is added from the palette to the colour on the brush. You can use this feature to create gentle transitions between colours etc.

- You can also completely replace the current colour of a brush by a colour from the palette, if you dip the brush in it and stir long enough (i.e. several seconds), or if you click on the colour in the palette using the right mouse button or the pen with its button pressed.

For more details, see the section on Choosing colours and transparencies.
The Stamp Browser

The topmost component of the Stamp Browser is the name of the category. To see all categories, click on the arrow and a drop down menu opens. Select a category. All related stamps appear below the name of the category. To select a stamp, click on it. If you now click on your picture, the stamp will be printed at that position. At the bottom of the Stamp Browser there are four additional values that can be set:

- **Size of the stamps** (see the section on Simple use of stamps).
- **Spacing** between two successive pictures when a stamp consists of a stack of pictures.
- **Random Spacing** tick box, see the description of the Stamps control menu.
- **Shuffle** tick box, see the description of the Stamps control menu.

For details on how to use stamps and the Stamp Browser, see the section on Adding stamps.
The Animation toolbar

**Previous Frame Item** Each click of this button displays the previous frame item manually (ignoring the corresponding time delay). If the first frame item of the sequence is currently displayed, the next click displays the last frame item – even if the animation loop is turned off.

If the preview is in **Play Forward** or **Play Backward** mode and you click on this button, the preview loop will be interrupted.

**Next Frame Item** Each click of this button displays the next frame item manually (ignoring the corresponding time delay). If the last frame item of the sequence is currently displayed, the next click displays the first frame item – even if the animation loop is turned off.

If the preview is in the **Play Forward** or **Play Backward** mode and you click on this button, the preview loop is interrupted.

**Play Backward** This button toggles to **Preview** mode (if it is not already on) and starts playing the same sequence of frame items as when the **Play Forward** button was pressed, but in the reverse order (using the same mechanism of time delays).

If the previewed image has the animation loop option turned on and the **Play Backward** button is pressed, the sequence of frame items will be played backwards continuously.
If you click on the **Play Backward** button again, the **Preview** mode will close and Natural Art will change to **Painting** mode.

**Stop Playing**

This is active only in **Preview** mode. It pauses the sequence of frame items. Then you can either click on it again to resume playing or click on the **Play Backward** or **Play Forward** buttons, thus switching back to **Painting** mode.

**Play Forward**

This button toggles to **Preview** mode (if it is not already on) and starts playing the whole sequence of frame items of the frame currently selected in the **Organizer**.

The corresponding **time delays** are used to specify how long each frame item is displayed before it is replaced by the next one.

If the previewed image has the **animation loop** option turned on and the **Play Forward** button is pressed, the sequence of frame items will be played repeatedly. If there are more frames currently selected in the **Organizer**, all their frame items are displayed step by step in one loop.

If you click on the **Play Forward** button again, the **Preview** mode will be closed and Natural Art will swap to **Painting** mode.

**Insert New Frame Item Before**

Inserts a new empty frame item before the selected frame item. It has the same settings (size, background colour and background picture) as the selected frame item.

**Insert New Frame Item After**

Inserts a new empty frame item after the selected frame item. It has the same settings (size, background colour and background picture) as the selected frame item.

**Delete Frame Item**

Deletes the selected frame item.
Minimize Picture

Reduces the currently selected frame item by removing all outside columns and rows that contain only transparent pixels. Note that this operation does not spoil the relationship between the picture and its HotSpot.

Show And Specify HotSpot

This is the same as choosing the View->Show and Specify HotSpot option.

For further details see the section on HotSpots and also the description of the HotSpot dialogue box.

For more details, see the section on Preview mode.

The Organizer

This is the central organizing panel of Natural Art whenever you work with several pictures or whenever you work with stacks of pictures (in particular RNA or LGF images, but also animated GIF files, animated icons etc.). It helps you to organize all the images open in your desktop. Within a selected image it helps you to organize all its frames. Within a selected frame, it helps you to organize all its frame items.

For more details, see the section on the Organizer.
The Colour Chooser

This makes it possible to either see or set the currently selected colour to be used for drawing, painting, filling, colour replacing, adding the text etc. This chooser contains:

- One of three possible colour models, for more details see the section on Choosing colours and transparencies.
- **Transparency slider** to inspect or set the level of transparency of the currently selected colour. Valid values are between 0 and 255.

To replace the colour model by a different one, choose the View->Colour Model option.

The Zoom Settings tool window

This tool window contains:

- The **level of zoom** for the picture displayed. It may be any value from 5% to 99% (zoom out), or from 100% up to 25600% (zoom in). Key combinations can be used instead. If you press Ctrl W or Ctrl + the picture in the Picture area is zoomed in one step higher in the sequence 5%, 10%, 20%, 25%, 33%, 50%, 100%, 200%, 300%, … etc. If you press Ctrl Q or Ctrl –, the picture is zoomed out one step in the same sequence. (Use the + and – on the number pad.)
  The other options for zooming are the Toggle Zoom button of the Main toolbar or the View->Zoom option.
- A thumbnail view of the whole picture with a **highlighted area** that represents the area that is currently enlarged in the working area of the paper. This highlighted rectangle can be dragged using the left mouse button or the pen within the whole thumbnail for quick and easy navigation. Alternatively, you can move around using the horizontal and vertical scroll bars of the Paper area.
• **Transparent Pixels** tick box. If ticked, all transparent pixels of the picture are highlighted by a black dot in the middle of the zoomed point (providing that you are zoomed in to 400% or more). Do not confuse the transparent pixels of the picture (i.e. certain parts of the picture that are completely transparent when used in the Imagine environment as RNA shapes, ICO, ANI, CUR, GIF, DIB) with **partly transparent colours**.

**Grid** tick box. If ticked, a grid of lines is displayed (providing that you are zoomed in to **400%** or more). These lines help you to paint, draw and navigate in the zoomed picture. The four images overleaf demonstrate all combinations of the **Transparent Pixels** and **Grid** tick boxes.
For further information see the section on Zooming.

The Nibs toolbar

![Nibs toolbar images]

Each brush and painting effect has a predefined nib size, however you may require other sizes. To select a different size use the Nibs toolbar. It contains two groups of settings:

- **Nib size.** Valid values are between 1 and 100 and this setting is accepted by all brushes for painting, for applying all painting effects and for adding shapes.

- **Nib shapes.** You can choose one of round nib, square nib, brush nib, random nib and custom nib. To set the custom nib, you have to specify a selection first and set it as a nib by choosing the Paint with Selection option. Note that nib shapes are recognized only by painting effects. Overleaf you can see the result of erasing with different shapes of nibs. In the left most example the round nib was used for erasing, however the level of transparency was also set to 200.
To make use of different nib shapes for drawing, choose the **basic drawing** option, then select a nib size and shape, then draw lines or any other shapes (including free hand drawing).

**The Colour Settings tool window**

![Colour Settings Tool Window](image-url)
This displays the code of the currently selected colour. The colour is represented both in Red-Green-Blue RGB notation and Hue-Saturation-Value HSV notation. You can either inspect the current colour here or re-set it.

Note, however, that modifying any of these settings also updates the alternative notation and the setting in the Palette, Colour Chooser and colour preview in the Status line. Conversely, selecting a different colour in an alternative way updates all the settings in this window.

Note also that if you set View->Colour Model to Display Palette and select a colour that does not match any colour of the palette model, no selection is displayed in the Colour Chooser.

The Colour Settings window also shows the currently selected level of transparency that is directly connected to the Transparency slider of the Colour Chooser. Valid values are between 0 and 255 inclusive.

The Status line

The Status line is the horizontal line in Natural Art that appears at the bottom of the main window. It provides contextual information about the currently selected colour, tool or menu option, together with some additional useful details.
Exploring the workspace

In particular it displays:

- **Colour preview**, i.e. the currently selected colour to be used for drawing, painting, filling, replacing colour, adding text etc.

- **Contextual information** about the currently highlighted menu option. When you open a menu (either by a left or right mouse click), each option's short description is displayed in the first field of the Status line.

- **Contextual information** about each button of each toolbar and tool window if you point to it using the mouse or graphics pen.

- The **current position** of the pointer (if you move it within the paper).

- When defining a **selection**, the third and fourth fields of the Status line show the **position** of the upper left corner of the selection rectangle and the last two fields show its current **width and height**.
Exploring the workspace
4 Working with a single picture

To get the most from Natural Art, you should learn all about its tools, techniques, features and modes. The following list gives a detailed overview of all the fundamental tools and features that are available when working with a single picture:

4.1 Choosing a brush

Natural Art offers a wide range of painting tools – a palette of artistic brushes. You can use any of them to create natural looking paintings. Note that for more technical drawings, instead of using artistic brushes you should use the basic drawing tool. Also, when you are going to use a brush, the following settings determine the final appearance:

- Which type of brush you have selected.
- Which colour and level of transparency is selected.
- What nib size is selected.
- If anti-aliasing is on or off.
- If any texture is set.
- If any motif is set.
- If any level of symmetry is set.

To select a brush, either click on its icon on the Painting and Effects toolbar or open the Brushes toolbar and choose the tool in its top most part or choose the Paint->Brush option and select it from the menu that appears.
Felt pen

Use felt pens to draw bright and dense lines and paintings.

Note that:

- The density of a colour increases slightly for repetitive strokes.
- If you use a pressure-sensitive graphics tablet and apply a higher pressure, the boldness of the trace increases only slightly. The density of the applied colour remains the same.
- You can easily cover a light shade by a darker one. However, it is almost impossible to cover a dark shade by a lighter one.
- If you overlay one colour on a second, the result is usually darker than either of the separate colours.
**Felt brush**

Use the felt brush to draw bright, dense and sharp lines and paintings.

Note that:

- The density of a colour increases slightly for repetitive strokes.
- If you use a pressure-sensitive graphics tablet, the trace responds very sensitively to the pressure on the pen and the direction of the stroke.
- You can easily cover a light shade by a darker one. However, it is almost impossible to cover a dark shade by a lighter one.
Pencil

Use pencils to sketch and draw solid fine lines, gentle and sensitive curves for natural drawings and colouring.

Note that:

- The density of a line drawn by a pencil does not increase even for repetitive strokes.
- If you use a pencil for drawing an outline, it will be clean, steady and distinct, yet gentle and smooth.
- If you use a pressure-sensitive graphics tablet and increase the pressure, the trace will be slightly bolder and slightly denser.
- You can partly cover a light shade by darker ones. You cannot easily cover dark shades by lighter ones.
- You must be very careful and patient if you want to colour a whole area using a pencil. Even then the area will not be quite solid.
- Pencils combined with varying levels of transparency are good for shading.
**Watercolour**

Use watercolours to paint realistic, soft and dense paintings with several layers of colours (of close or distinct tones).

Note that:

- When you apply one long stroke with a watercolour brush, the colour slowly dries out and fades. If you stop the stroke and start again the trace will be dense again - it is as if you dipped the brush into the colour again.

- If you use a pressure-sensitive graphics tablet, you can obtain lines of varying thickness and density by changing the pressure on the pen. However, note that the higher the pressure, the quicker the line dries out. Note also that the smaller the size of the brush, the less colour it can absorb and thus the quicker it dries out.

- If you cover one colour by another, they slightly blend together.

- It is difficult to overlay a dark shade with a lighter one. You can only do it to a certain extent by using repetitive strokes.

- If you paint the whole area using a watercolour, it will not be solid.

- It is worth combining watercolours with colour pencils.
Colour tub

Use the colour tub to paint semi-strong and semi-light shades that are dense and blend with the tones underneath.

Note that:

- When you apply one long stroke with a colour tub, the colour slowly dries out and fades. If you stop the stroke and start again the trace will be dense again - it is as if you dipped the brush into the colour again.

- If you use a pressure-sensitive graphics tablet and apply a light pressure, you will obtain a faint trace of colour, which hardly covers the lower layers of the painting. If you increase the pressure, the boldness and density of the colour will increase considerably, as will the volume of the applied colour. However, note that the higher the pressure, the quicker the trace dries out.

- Although the colour is dense, it blends slightly with the colour beneath and smudges the lower layers.
Cromar

Use cromars to get bright and dense colours that filter through the upper layers of your painting to a slight extent. Using cromars is similar to painting on glass.

Note that:

- When you apply one long stroke with a cromar, the colour slowly dries out. If you want to paint with a wet brush all the time, use short strokes only.
- If you use short strokes, you can cover the whole area with a good, solid colour.
- Whilst your cromar brush is wet with colour, you can easily overlay the painting beneath, even dark shades by lighter ones. The lower layer of colour does not smudge but gently filters through the upper colour.
- If you use a pressure-sensitive graphics tablet and change the pressure on the pen, you will obtain lines of considerably varying density and boldness. However, note that the higher the pressure, the quicker the trace dries out.
Acrylic

Use acrylics to get dense and bright colours. The lines you obtain are not quite solid; you can see the traces of single bristles.

Note that:

- Acrylic paints overlay any shades beneath perfectly. You can cover one colour by another easily, even a dark shade by a much lighter one. However, the density of an acrylic colour does not increase with repetitive strokes. When repeating strokes, you just leave more colour at the same place.

- When you apply one long stroke with an acrylic, the colour dries out slowly. If you want to paint with a dense shade all the time and thus overlay the painting beneath perfectly, use short strokes only.

- If you use a pressure-sensitive graphics tablet, you can obtain lines of considerably varying thickness by changing the pressure on the pen. However, note that the higher the pressure, the quicker the line dries out.
Wax crayon

Use wax crayons for soft, uneven lines with gentle, dim colours. They leave a trace very easily, therefore you can use them for quick sketches.

Note that:

- The density of a colour does not increase much even for repetitive strokes. With repetitive strokes, however, you leave more colour at the same place.
- Lines are rather blunt and thus not very convenient for detail work.
- If you use a pressure-sensitive graphics tablet and apply a higher pressure, the boldness of the trace will increase slightly and the crayon will leave more colour on the paper. By applying an increased pressure and decreased transparency you can obtain an excellent gradation of shades and shadows.
- It is nearly impossible to cover one colour by another, even a light tone by a darker one.
- If you want to obtain a dense black outline, you have to repeat the same stroke several times.
Oil pastel

Use oil pastels for bright, vivid but uneven strokes and soft and pliable traces.

Note that:

- The density of a colour does not increase much even for repetitive strokes. With repetitive strokes, you just leave more colour at the same place. If you want to get a dense black outline, you have to repeat the same stroke several times.
- You can use oil pastels for bold strokes, and partly also for gentle lines and a degree of detail.
- If you use a pressure-sensitive graphics tablet, you can obtain lines of slightly varying thickness by changing the pressure on the pen. With an increased pressure you apply more colour.
- If you overlay a colour by an oil pastel, you will partly smudge the lower colour.
- You can partly cover one colour by another, even a dark shade by a much lighter one.
- Oil pastels are good for shading.
Chalk

Use chalks for painting bold, inaccurate lines in faint and faded tones. Chalks are very popular with artists for landscape painting, portraits, figures or scenes of few tones.

Note that:

- The density of a colour does not increase much even for repetitive strokes. With repetitive strokes, you just leave more colour at the same place.
- Lines are blunt and thus not very convenient for details and tiny objects.
- If you use a pressure-sensitive graphics tablet, you can obtain lines of slightly varying thickness by changing the pressure on the pen.
- You can easily cover one colour by another, even a dark tone by a lighter one.
Charcoal

This is similar to chalk, but mostly used only in dark tones. It is very suitable and convenient for quick sketches, this gentle tool inspires you to experiment and create. You can use it both for soft curves and expressive, strong strokes.

Note that:

• The density of a colour does not increase much even for repetitive strokes. With repetitive strokes, you just leave more colour at the same place.

• If you use a pressure-sensitive graphics tablet, by applying a higher pressure you will obtain bolder lines. However, the bolder the stroke gets, the greater its bluntness.

• Charcoal is excellent for shading.

• Charcoal is extremely popular with artists, because they can easily blur it using their fingers. You can blur the line by applying erasing or other painting effects.
Spray

This is similar to chalk, but even less dense. It is often used with bright synthetic colours. It is also suitable and popular for quick and inaccurate sketches. You can use it both for soft curves and expressive, strong strokes.

Note that:

- The density of a colour does not increase much even for repetitive strokes. With repetitive strokes, you add more colour at the same place.
- If you use a pressure-sensitive graphics tablet, by applying a higher pressure you will obtain bolder lines.
- Sprays are excellent for shading.
- It is nearly impossible to cover one colour by another, even a light tone by a darker one.
4.2 Choosing colours and transparencies

Obviously, colour is one of the key concepts of Natural Art. Colour is used in two relatively separated areas in Natural Art:

- As a background colour for the paper and Preview area. To find out the current setting or to modify it, choose the View->Paper Properties option, or choose the Background Colour… option in the Preview area menu.

- As a colour selected for drawing, painting, adding text, adding shapes, filling, colour replacing etc. To find out which colour is currently selected, you can inspect the small Preview area at the left-hand end of the Status line, or you can see it in the cursor itself when Natural Art is in Painting mode, or you can inspect the Colour Chooser or, for a more technical specification, the Colour Settings window.

There are several ways in which you can set a colour for drawing, painting and adding shapes:

- Select a brush in the Brushes toolbar and a selection of the colours most often used with this tool is offered (the picture overleaf illustrates some of these sets of colours).

- If you want to select a colour that is missing in the Brushes toolbar, you can go into the Palette and either select a colour there or slightly modify the currently selected colour by dipping the brush into a colour.

- If you want to select a colour that is not in the selection shown, you should open the Colour Chooser.

- If you want to set a colour exactly, specified by its internal code, go into the Colour Settings window.

- Note also that for very advanced users sometimes it is necessary to open the Colour Settings window and specify another colour tolerance.

- Sometimes you may want to pick up the colour (and its level of transparency) from another part of the picture. To do this you should use the Colour Picker.
To learn more about setting colours and transparencies, see the sections on:

- The Brushes toolbar
- The Palette toolbar
- The Colour Chooser
- The Colour Settings tool window
- Colour Picker
- Level of transparency: the Transparency slider
- Colour models

**Colour Picker**

Often you need to find out which colour is used in a certain area of your picture and what level of transparency it has. To find this, click on the Colour Picker button on the Main toolbar, then click on the pixel in your picture. Now, you can see the current colour and transparency of that particular pixel in the Colour Chooser. This allows you
Working with a single picture

to use exactly the same settings for further work or modify the settings slightly and use those instead. After having picked the colour and transparency you can also find the exact values in the Colour Settings window.

**Level of transparency: the Transparency slider**

For each colour selected for painting, drawing or adding shapes, text etc. you can set a level of transparency, i.e. the degree to which it should be added to the previously drawn picture on the paper. Its value is between 0 and 255 (i.e. 100%) and this value can be inspected or set on the Transparency slider within the Colour Chooser. Note that drawing with the transparency set to 255 adds nothing to the paper at all. Pixels coloured in this way are identical to the initial transparent pixels of the paper. To inspect the current colour and current level of transparency of a pixel in the paper, click on the Colour Picker button then click on the pixel and read its current settings in the Colour Chooser (and the Colour Settings window).

Below you can see the Colour Chooser (with three alternative colour models) with the transparency slider set to 50. The left most position corresponds to 0, the right most to 255 transparency.

Drawing with a partly transparent colour means that the colour (line, rectangle, text etc.) does not completely cover the previous drawing on the background, as illustrated in the picture below. The red filled rectangle has been covered by a sequence of polygons and letters with increasing transparency. The first polygon and letter are not transparent at all. The next polygons and letters have values of 50, 100, 150 and 200 for their levels of transparency respectively. Therefore, the rectangle below is increasingly visible through the polygon or letter.
Colour models

There are three different technical models implemented in Natural Art for referring to the colours to be used for drawing, painting, filling, printing etc. If you choose the View->Colour Model option, a submenu will open giving three options:

These correspond to the three visual ways in which you can interactively specify colour.

- **HSV model** (hue, saturation, value components) is a circle with a triangle in the middle. To specify a colour you drag a small round mark within the colour circle (thus specifying the hue component) and/or a white cross within the triangle (specifying saturation and value).
• **RGB model** (red, green and blue components) is a cube in which you can drag either three white dots along three edges of the cube, or three white circles within the three sides of the cube, or a white cross within the whole space of colours, thus specifying the contribution of each of the three components to the current colour.

• **Palette model** offers 256 pre-selected colours. To select a colour click on it.

**Choose Colour dialogue box**

This opens whenever you click on the background colour preview in the Paper Properties dialogue box or if you choose the Background Colour… option in the Preview area menu. It allows you to inspect or modify the current (background) colour which is represented here in three different ways:

• Using a visual **colour model**.

• In Red-Green-Blue (RGB) notation.

• In Hue-Saturation-Value (HSV) notation.

Modifying any of these settings updates the other two notations.

![Choose Colour dialogue box](image)

If you prefer another colour model in this dialogue box, choose it in the View->Colour Model submenu.
4.3 Setting a nib

Use the Nibs toolbar to find out or set:

- The current nib size.
- The current nib shape.

Note that whilst the nib size is recognized by all artistic brushes, the nib shape is recognized only by painting effects, like basic drawing, erasing or smearing. If you, for example, need to draw rectangles with round or sharp corners, select basic drawing, select a colour, nib size and different nib shapes (round, square, brush and random in this case) to get results similar to those below:
4.4 Adding shapes

Use these tools to add geometrical figures or freehand drawing parts to your picture. The following settings determine the resulting appearance:

- Which shape you have selected.
- Which **brush** or **painting effect** is selected.
- Which **colour and level of transparency** is selected.
- What *nib size* is selected.
- Which **nib shape** is selected. (Note that this is only possible if you draw with **painting effects**, not with artistic brushes.)
- Which **painting effect** is selected.
- If **anti-aliasing** is on or off.
- If any **texture** is set.
- If any **motif** is set.
- If any level of **symmetry** is set.

The following elements can be selected and added to your picture:

- Freehand drawing: solid and dotted
- Line: single and rays
- Ellipse or circle: outline and filled
- Rectangle or square: outline and filled
- Regular polygon: outline and filled
- Star: outline and filled
- Spline: plain, closed and filled
- Polygon: plain, closed and filled
See also:

- Adding text
- Filling and replacing colours
- Adding stamps

Note that adding shapes with the right mouse button or pen's eraser always erases the selected shape in your picture:

Freehand drawing: solid and dotted

To produce a solid freehand stroke:

1. Click on the Continuous Curve button on the Shape toolbar or choose the Paint->Shape->Freehand Drawing->Continuous Curve option.
2. Move the pointer onto your picture.
3. Then drag the pointer to draw solid freehand strokes without any constraints.
4. Complete each stroke by releasing the mouse button or lifting the pen.

To draw a dotted freehand stroke:

1. Either click on the Dots button on the Shape toolbar or choose the Paint->Shape->Freehand Drawing->Dots option.
2. Continue as above.
Working with a single picture

Note how the selected **brush** and its **size** result in different looking strokes. Note also that if you draw with the graphics pen and you choose freehand drawing, you can vary the line width by changing the pressure on the pen. Press hard for bold lines, press lightly for fine lines.

![Image of lines drawn with different pressures]

**Line: single and rays**

To draw a **straight line**:

1. Click on the **Line** button on the **Shape** toolbar or choose the **Paint->Shape->Line->Single Line** option.
2. Move the pointer onto your picture.
3. Click once to specify the starting point of the line.
4. Then drag the pointer.
   The elastic line from that point to the current position of the pointer stretches.
5. Click for a second time to specify the end point of the line.

If you hold down the **Shift** key while you drag the pointer, the heading of the new line segment is forced to be either horizontal, diagonal or vertical.

Note how the selected **brush** and its **size** affect the appearance of the lines. For example, a watercolour line dries out slowly. Notice how different types of brushes apply colour in different ways when they cross each other. Note also that **it is not possible** to vary the straight line width by changing the pressure on the graphics pen.
You can get very attractive results if you make use of an alternative straight line shape – the Rays tool:

1. Click on the Rays button on the Shape toolbar or choose the Paint->Shape->Line->Rays option.
2. Move the pointer onto the page.
3. Click to specify the origin of the ray.
4. Drag in one direction.
5. Then continue using a circular or elliptical movement.

Experiment with different brushes, colours, level of transparency and textures on your own.

Rays with green shades of oil pastels
Ellipse or circle: outline and filled

To draw an outline of an ellipse or circle:

1. Click on the Ellipse or Circle button on the Shape toolbar or choose the Paint->Shape->Ellipse->Outline option.
2. Move the pointer onto your picture.
3. Click once to specify a corner of the (imaginary) frame into which the outline should fit.
4. Then drag towards the opposite corner of that frame.

Note that:

- If you hold down the Shift key while you drag the pointer, the ellipse will be forced to be an exact circle.
- If you hold down the Ctrl key, the starting point (your initial click) will specify the centre of the ellipse or circle instead of the corner of its imaginary frame.
- If you hold down both the Shift and Ctrl keys while you drag the pointer, the ellipse will be an exact circle and your initial click will specify its centre.

To draw a filled ellipse or circle:

1. Click on the Filled Ellipse or Circle button on the Shape toolbar or choose the Paint->Shape->Ellipse->Filled option.
2. Continue as above.

The three notes above about the use of the Shift and Ctrl keys apply to filled ellipses in the same way.

Note how the selected brush and its size affect the appearance of the ellipses and circles. Note also that with this shape it is not possible to vary the width of the outline by changing the pressure on the graphics pen.
Rectangle or square: outline and filled

To draw an outline of a rectangle or square:

1. Click on the Rectangle or Square button on the Shape toolbar or choose the Paint->Shape->Rectangle->Outline option.
2. Move the pointer onto your picture.
3. Click once to specify a corner of the outline.
4. Then drag towards the opposite corner of the outline.

Note that:

• If you hold down the Shift key while you drag the pointer, the rectangle will be forced to be an exact square.

• If you hold down the Ctrl key, the starting point (your initial click) will specify the centre of the rectangle or square instead of one of its corners.

• If you hold down both the Shift and Ctrl keys while you drag the pointer, the rectangle will be an exact square and your initial click will specify its centre.
To draw a filled rectangle or square:

1. Click on the **Filled Rectangle or Square** button on the **Shape** toolbar or choose the **Paint->Shape->Rectangle->Filled** option.
2. Continue as above.

The three notes on the previous page about the use of the **Shift** and **Ctrl** keys apply to filled rectangles in the same way.

Note how the selected **brush** and its **size** affect the appearance of the rectangle outlines and fills. Note also that with this shape **it is not possible** to vary the width of the outline by changing the pressure on the graphics pen.

---

**Regular polygon: outline and filled**

To draw an **outline of a regular polygon**:

1. Click on the **Regular Polygon** button on the **Shape** toolbar or choose the **Paint->Shape->Regular Polygon->Outline** option.
2. Move the pointer onto your picture.
3. Click once to specify the centre of the outline.
4. Then drag in any direction towards one of the vertices. The current number of vertices (which is the same as the number of sides) is specified by the **Vertices Count** icon.

5. To increase or decrease the number of vertices, use the adjacent arrow buttons. The smallest possible number of vertices is 3, the largest is 25.

To draw a filled regular polygon:

1. Click on the **Filled Regular Polygon** button on the **Shape** toolbar or choose the **Paint->Shape->Regular Polygon->Filled** option.

2. Continue as above.

   Note how the selected **brush** and its **size** affect the appearance of the polygon outlines and fills. Note also that with this shape it **is not possible** to vary the width of the outline by changing the pressure on the graphics pen.

---

**Star: outline and filled**

To draw an **outline of a star**:

1. Click on the **Star** button on the **Shape** toolbar or choose the **Paint->Shape->Star->Outline** option.

2. Move the pointer onto your picture.

3. Click once to specify the centre of the outline.
4. Then drag in any direction towards one of the vertices.
The current number of vertices is specified by the **Vertices Count** icon.

5. To increase or decrease the number of vertices, use the adjacent arrow buttons.
The smallest possible number of vertices is 3, the largest is 25.

To draw a filled star:

1. Click on the **Filled Star** button on the **Shape** toolbar or choose the **Paint->Shape->Star->Filled** option.

2. Continue as above.

Note how the selected **brush** and its **size** affect the appearance of the star outlines and fills. Note also that with this shape **it is not possible** to vary the width of the outline by changing the pressure on the graphics pen.

Polygons: simple, closed and filled

To draw a simple **polygon** (i.e. a polygon that is neither connected nor filled):

1. Click on the **Polygon** button on the **Shape** toolbar or choose the **Paint->Shape->Polygon->Simple** option.

2. Move the pointer onto your picture.

3. Press the button to specify its initial mark.

4. Then continue in exactly the same way as with **simple splines**.
The only difference is that with polygons, all the specified marks are connected by line segments instead of smooth curves.

To draw a **closed polygon** (i.e. a polygon that always has a section connecting its first and last points):

1. Click on the **Closed Polygon** button on the **Shape** toolbar or choose the **Paint->Shape->Polygon->Closed** option.
2. Move the pointer onto your picture.
3. Press the button to specify its initial mark.
4. Then continue in exactly the same way as with simple polygons.

   The only difference is that there is an extra elastic line connecting the first and last marks.

   Adding a new point (mark) to a closed polygon always means dividing a section into two parts, i.e. inserting new mark somewhere between two previously connected marks.

To draw a **filled polygon** (i.e. a polygon that is connected and filled):

1. Click on the **Filled Polygon** button on the **Shape** toolbar or choose the **Paint->Shape->Polygon->Filled** option.
2. Move the pointer onto your picture.
3. Press the button to specify its initial mark.
4. Then continue in exactly the same way as with closed polygons.
Note that filled polygons may contain some transparent regions. This happens whenever a part is covered by an even number of layers (foldouts) of the filled polygon. Note also that polygons and filled polygons can be used for creating rather complex objects, see below.

Spline: simple, closed and filled

To draw a simple spline (i.e. a spline that is neither connected nor filled):

1. Click on the Spline button on the Shape toolbar or choose the Paint->Shape->Spline->Simple option.
2. Move the pointer onto your picture.
3. Press the button to specify its initial mark highlighted by a small cross.
4. Whilst keeping the button pressed, drag the pointer, together with the second mark, which is connected to the previous one by an elastic line, to any position you want and release the button.
   This positions the second point and constructs the first section of the spline.
5. With the button released, move the pointer a bit further.
   There will not be an elastic line until you press the button again.
6. Press the button and the next mark appears at the position of your pointer, connected to the previous one by an elastic line.
7. Drag the mark to the position you want and release.
Note that dragging the third (and following) marks reshapes the previous section of the spline.

8. Repeat this procedure as many times as you need.

9. Finally, click the right mouse button or pen's button to complete the spline.

When you complete the spline, all temporary marks disappear and their positions are connected by a spline using the current brush, size, colour and other settings. (Alternatively, you can finish the whole process by clicking another shape icon.)

Be aware of the fact that when you release the button, then move the pointer a bit further and press again, one of the following things happens:

- If you click very close to the previous mark, the mark itself will jump (together with the elastic line) to the pointer and will continue to be dragged.

- If you click close to the initial mark of the spline, a new section of the spline will be created between the initial mark and the current position of the pointer. This allows you to add new sections to the beginning of the spline.

- If you click very close to any of the previously created marks or if you click on an existing mark, it will jump to the pointer and will allow you to reposition it by dragging. This allows you to reshape the spline.

- If you click very close to any section (to the line itself), a new mark will be created there, thus dividing the corresponding section into two parts. This allows you to add more inner marks and shape the spline very precisely.
Note how the selected brush and its size affect the appearance of the splines. Note also that with splines it is not possible to vary the width of the line by changing the pressure on the graphics pen.

To draw a closed spline (i.e. a spline that always has a section connecting its initial and terminal points):

1. Click on the Closed Spline button on the Shape toolbar or choose the Paint->Shape->Spline->Closed option.
2. Move the pointer onto your picture.
3. Press the button to specify its initial mark.
4. Then continue in exactly the same way as with plain splines.

The only difference is that there is an extra elastic line connecting the initial and terminal marks. Adding a new point (mark) to a closed spline always divides a section into two parts, inserting a new mark somewhere between the two previously connected marks.

It requires a lot of experience to create a closed spline of the desired shape. In the picture above you can see the desired shape in a light pink colour. First you create points 1, 2 and 3. Then you click on the line between points 2 and 3, thus creating point 4, and drag it to its final position. Finally you click on the line between points 1 and 3, thus creating point 5, and drag it to its final position.

To draw a filled spline (i.e. a spline that is connected and filled):

1. Click on the Filled Spline button on the Shape toolbar or choose the Paint->Shape->Spline->Filled option.
2. Move the pointer onto your picture.
3. Press the button to specify its initial mark.

4. Then continue in exactly the same way as with closed splines.

Note that the filled spline may contain some transparent regions, see below. This happens whenever a part is covered by an even number of layers (foldouts) of the filled spline.

If you are creating a closed or filled spline, you can get some very bizarre shapes. Before completing the process by clicking with the right mouse button or pen's button you can drag any mark of the spline, thus getting surprising variations on the previous shapes, see below.
4.5 Adding text

This tool allows you to add text to your picture. To do so:

1. Click on the Text button of the Shapes toolbar or choose the Paint->Shape->Text option.

2. In the Text window type in a letter, a word, a sentence or even paragraph or several paragraphs of text. Alternatively insert text in the Text window by pasting it there from the Clipboard.

A sample text frame (the upper one) and Text window (the lower one) are shown below.

3. Edit and format the text here by:
   - Specifying the font type, weight (normal, bold, italic, underline) and size.
   - Specifying the horizontal alignment of a paragraph (left, centre, right or justified).

The formatting is always applied to the whole text. If you want to add text of different colours, sizes, fonts, alignment etc. to your picture, you must do it piece by piece and format them differently.

As you edit the text, a preview of it in the current font type, colour, weight, size and alignment is built and displayed in the text frame.
4. Click inside the text frame and drag it to any position within the page.
   The contents of the text frame can still be edited or formatted in the Text window.

5. Adjust its position, copy it and/or resize it as necessary:
   • Use the arrow keys on the keyboard to move the text frame within the page.
   • Hold down the Ctrl key and drag the text frame to another position. A copy of the text stays at the previous position on your picture. However, the contents of the text frame can still be edited or formatted in the Text window.
   • Drag any of the six marks around the frame and directly modify the font size of the text. Note that when you drag any of these marks, the opposite one stays at its position. Note also that if you resize the text in this way, the current font size box in the Text window is updated accordingly.

6. When you are happy with the contents and position, click anywhere away from the text frame.
   The current contents of the text frame are added to your picture at the current position and the text frame disappears.

Note that once you have added the text to the page, it becomes a part of your picture and cannot be re-formatted or edited as text any more.

If you click again within the page (whilst the Text window is still open), the text frame will reappear at the position of the mouse click and will contain the same text:

• Choose another colour to change the current colour of the text.
• Choose another brush to change the look of the text.

If you click on the Text button again, the current contents of the text frame will be printed on your picture and both the text frame and the Text window will disappear. You can do the same by closing the Text window. Note that if you open it again, it will contain the text previously entered. The text frame will re-appear at its recent position with the previous text in the current colour and brush style.
Working with a single picture

Note that the final appearance of the text added to your picture is determined by:

- The text itself.
- What the current font setting, weight and size are.
- What the paragraph alignment is.
- Which **colour and level of transparency** is selected.
- Which **brush** or **painting effect** is selected.
- If **anti-aliasing** is on or off.
- If any **texture** is set.
- If any **motif** is set.
- If any level of **symmetry** is set.

![Image of text with various effects applied](image.png)

Note that if you add text to your picture while horizontal and/or vertical symmetry is on, then two or four copies of the same text will be added. However, the additional copies will be horizontally and/or vertically mirrored.
4.6 Undo and Redo mechanism

All the steps you take when creating your picture (either a simple or complex image) can be undone. This includes adding strokes with a brush, adding shapes, text or stamps, filling, resizing, reordering images within the Image Organizer or reordering frame items within a frame, applying any transformation to any part or parts of your picture etc. Any of these steps can be undone - a long sequence of restoring steps is available.

To provide this valuable feature, Natural Art remembers your steps and their results. As soon as this undo sequence is no longer empty, the Undo button on the Main toolbar is enabled. As soon as you apply the Undo button, the redo sequence becomes non-empty and the Redo button is enabled so that you can re-make an undone step.

To undo a step:

1. Click on the Undo button or choose the Edit->Undo <last change> option.

To redo a step:

1. Click on the Redo button or choose the Edit->Redo <last change> option.
4.7 Filling and replacing colours

**Filling** and **replacing colours** always means replacing a certain colour (or several, very similar colours) by the **currently selected colour** or by the **currently selected motif** (see below). To fill or replace a colour:

1. Select the new colour to be used.
2. Click on the **Fill** button of the **Main** toolbar or the **Colour Replacer** button of the same toolbar.
3. Point with the tip of the cursor at a pixel.
4. Click.

Filling and replacing differ as follows:

- **Filling** means covering the area (surrounding the pixel on which you have clicked) that is bordered by any colour or colours different from the area colour. The surrounding area is a continuous area around the pixel where all points have the same colour as the pixel itself. Note that the area must have no breaks in its border, otherwise the colour will leak through and fill a larger area or even the whole paper.

- **Replacing colour** means replacing all points of the **whole picture** by the currently selected colour.

When you fill or replace and keep the **colour tolerance** to 0% (this is the default value, see the description of the **Tool Settings** dialogue box) it is only pixels that are the same colour as the clicked pixel that are replaced. However, you may increase the colour tolerance. Then all points of a **similar colour** are replaced. If set to **100%**, the whole picture will be covered by the current colour.
4.8 Working with motifs

As an alternative to using the currently *selected colour*, you may choose a *motif* to be used to fill regions or to be used inside *filled polygons* and *filled splines*.

When you start working with Natural Art, no motif is set. To select a motif:

1. Click on the *Fill Motif* button of the *Main* tool bar

The following dialogue box will open:
2. Click on the small arrow under the word Name in the upper right corner of the Motifs dialogue box. A drop down menu of all available motifs will open.

3. Choose a motif.
   It will appear in the Motifs preview window.

![Motifs dialogue box](image)

Note that with any motif, you can modify the way in which the pattern is tiled to fill the shape, region or text. To do so, explore the Layout, Space and Offset components.

Each pattern is created by putting together four copies of the motif. Each particular motif may be rotated or flipped horizontally or vertically. In addition, any combination of these transformations is available through the Layout component:

1. Click on a motif in the Layout window.
2. Choose the rotation or flip from the additional drop down window.
3. Repeat this for each motif in the Layout and watch the result in the Preview window.
You can also use the following options:

- Set the **Horizontal Space** and/or **Vertical Space** to insert a space between the columns and/or rows of the pattern.
- Set the **Horizontal Offset** or **Vertical Offset** to specify the offset between the rows or columns of the pattern.

- If you select the **Colourize** option, all colours of the motif will be transformed to shades of the **currently selected colour**.
• Use the **Reset** button to remove all specified transformations.

• Note that the result of filling certain shapes with a motif also depends on the **texture** currently selected.

All motifs are stored in the **Motifs** subfolder of Natural Art in the form of device independent bitmaps *.DIB*. You can create your own motifs, add them to that folder and use them as a fill for any filled shape, region or text. Note also that any **texture** stored in the **Textures** folder of Natural Art can be copied into the **Motifs** folder and used as a motif.

The selected motif will take effect when you:

• **Add filled shapes**, i.e. filled ellipses, filled rectangles, filled regular polygons, filled stars, filled splines or filled polygons.

• **Fill** a region or **replace a colour**.

• **Add text**.

• Apply **painting effects** using filled shapes (such as **darkening** a region by adding a filled rectangle).
To stop using motifs, click on the **Fill Motif** button to turn it off.
4.9 Working with textures

A texture is (usually a small) piece of graphic - a pattern selected to produce the effect of an underlying textured surface on the paper while you draw on it, paint or add shapes, text etc. When you start working with Natural Art, no texture is set. To select one:

1. Click on the Paper Texture button of the Main tool bar.

The following dialogue box will open:

2. Click on the arrow at the top of the dialogue box to see the drop down menu of all available textures.

3. Choose one of them, for example Bricks, by clicking on the corresponding line.
Note that there are three levels at which you can apply the effect: **Soft**, **Normal** and **Hard**. The following picture illustrates the effect of the three levels on a freehand drawing with an oil pastel.

The selected texture is used when you:

- Freehand draw or add any **shape** such as a line, rectangle, polygon etc.
- **Fill or replace colour**.
- **Add text**.
- **Add stamps**.
- **Apply painting effects** like darkening etc.

The following picture was created using **Strong** texture, **Hard** style with **oil pastels** applied as **rays**.

**Textures** are **DIB** files saved in the **Textures** subfolder of Natural Art. When you select a texture from the Textures menu, Natural Art tiles it invisibly as an underlying hidden surface. Then, when you draw or paint, the texture influences the way in which the colour is added to the paper.
Note that for some textures you may find some painting tools and drawing styles work better than others.

Textures usually use different shades of grey with different **levels of transparency** and influence the drawing in the following way:

- The darker tones of the texture darken the colour that you apply using a tool. The result is that these pixels look as if they are in shadow.
- The lighter tones of the texture lighten the colour that you apply using a tool. These pixels look as if they are being lit.
- The less transparent the pixels of the texture, the greater the amount of your colour that is added.
- The more transparent the pixels of the texture, the smaller the amount of your colour that is added.

By following these four rules, you can develop your own textures and save them as **DIB** files in the **Textures** folder. The picture below illustrates the rules. The texture consists of six small squares. The three squares in the upper row have the same dark grey colour, which has an **RGB** code of **[45 45 45]**, however with increasing levels of transparency from **0** to **100** to **200**. The lower three squares have a light grey colour of **[190 190 190]** with similar levels of transparency **0**, **100** and **200**. You can see the effect below, on a drawing which was done with a pencil.

To stop using textures, click on the **Paper Texture** button to turn them off.
4.9 Adding stamps

Stamps are small pictures displayed in the Stamp Browser and organized in categories of related topics. You can browse through the categories, select suitable stamps and add them to your picture.

You can alter the appearance of the Stamp Browser as follows:

• If the Stamp Browser is completely hidden, click on the Stamps button of the Main toolbar or choose the View->Stamp Browser option to display it.

• If it is minimized (see the right part of the figure below), click on the small open mark in its title bar.

• If it is shown, click on the cross mark in its title bar to hide it completely or click on the close mark to minimize it.

• If the Stamp Browser is docked, you can click on its title bar and drag it to position the Stamp Browser anywhere within the screen.
Working with a single picture

The topmost component of the **Stamp Browser** is the name of the **category**.

To see the full list of stamp categories:

1. Click on the arrow.
   - A drop down menu opens.

To see the stamps within that category:

1. Select a category.
   - All related stamps appear below the name of the category.

To select a stamp:

1. Click on it.

If you now click on your picture, the stamp will be printed at that position.
At the bottom of the **Stamp Browser** you can find four additional components:

- A field for setting the **Size** of the stamps (see the section on **Simple use of stamps**).
- A field for setting the **Spacing** between two successive pictures when a stamp consists of a **stack of pictures**.
- The **Random Spacing** tick box, see the description of the **Stamps** control menu.
- The **Shuffle** tick box, see the description of the **Stamps** control menu.

Note that the final appearance of the stamp or stamps printed on your picture is determined by:

- Which stamp is currently selected. If it is a single picture or a **stack of pictures**.
- What the current settings are in the **Stamps** control menu.
- If **anti-aliasing** is on or off.
- If any level of **symmetry** is set.
- If any **texture** is set.

Experiment with different settings, modes and paper types on your own.

### Simple use of stamps

To use stamps:

1. Make sure that the **Stamp Browser** is shown.
2. In the drop down menu of categories find the one you are looking for, for example **Buildings**.
   
   Several related stamps appear below the name of the category.

3. Choose the stamp that you want to use in your picture and click on it.
4. Move the pointer onto the page and click.
   
   The stamp is printed there.
Now you can click several times to repeatedly print the same stamp at different locations. Note, however, that once you have printed the stamp on the page, you cannot move it – you can only **Undo** it.

If you want to have the stamp resized before it is printed on your picture, reset the **Size** component so that it is expressed either:

- As a percentage of the original size (such as **33%**, **50%**, **150%** etc.).
- In plain numbers such as **40** or **210** which specify the exact size of the resized image in pixels (whilst the ratio between the height and width of the original stamp is preserved).

Note also, that if you select a stamp and right click on your picture, the stamp will be **erased** from the background instead of being printed there.
**Drawing with a stamp**

To draw with a stamp:

1. Select a stamp and move the pointer onto the page.
2. Press the button and draw.
   
   The stamp is repeatedly printed along the path of the pointer.

First experiment with horizontal strokes only. Then experiment with any strokes, for example circular. Note that the stamp is first rotated and only then printed onto the page. Note that you will obtain different results if you start the stroke in a horizontal direction, then bend the stroke downwards or upwards, or if you start the stroke in a vertical direction.

If you draw with a stamp with the right button pressed, the stamp will be repeatedly **erased** from the background.

Note that you can also modify the spaces that Natural Art inserts between two successive prints of the stamp when you draw with it. By default this value is set to **100%**, i.e. one stamp is printed exactly next to the other, see the first row of houses below. However, you can click on the **Space** component of the **Stamp Browser** and express the spacing either:

- As a percentage of the size of the stamp (such as **50%**, **100%**, **150%** etc.) where, for example, **200%** means that each two successive prints are separated by a space which is the size of the stamp.
• In plain numbers such as 10 or 50 or -20 which specify the exact size of the space. That is, 0 means the same as 100%, 20 means that each space is 20 pixels, -10 means that two successive prints overlap by 10 pixels etc.

Note that you can tick the Paint->Stamp->Random Spacing option. If it is on, Natural Art will insert random spaces between prints of the stamp when you draw with it. In which case, the current value of the Space setting is used as the average value and all inserted spaces are between 0 and double that value, see below.
A stamp as a selection

To use a stamp as a selection:

1. Select a stamp and drag it from the Stamp Browser onto the page.
2. Release the button.

Instead of simply being printed onto the page, the stamp is put there with the selection marks and rectangle, so that before printing it onto the picture, you can resize it, rotate or process it like any other selection.

This method is useful whenever you want to position a stamp precisely or if you want to transform it before using it.

To get the current stamp as a selection in the centre of the paper:

1. Select a stamp.
2. Choose the Paint->Stamp->Use As Selection option.

See the description of the Stamps control menu.
Working with a single picture

Dragging a stamp with the right mouse button

To obtain a choice of options:

1. Select a stamp and drag it onto the page with the right button.
2. Release the button.

A menu of options will appear.

The options offered are:

- **Stamp**  
  Prints the stamp onto the page as it is.

- **Use As Selection**  
  Offers the stamp with selection marks, so that before printing it onto the picture, you can resize it, rotate or process it like any other selection.

- **Use As Background**  
  Opens a submenu with four styles (**Centre**, **Fit**, **Resize** and **Tile**) specifying how the current stamp should become the background of the paper, identical to the **Layout** option of the **Paper Properties** dialogue box.
Stamps with stacks of pictures

Some stamps that you choose in the Stamp Browser may in fact be stacks of pictures rather than single pictures. This happens whenever you use an Imagine image as a stamp, or a LGW SuperLogo image, animated GIF picture, animated cursor, animated icon etc. (All of these are sequences of pictures that can be created, explored or modified in Natural Art itself.) The option of using stacks of pictures as stamps in Natural Art makes the Stamp Browser even more powerful.

Before trying to understand the mechanism behind compound stamps, make sure that you understand what images are and what their frames and frame items are. Note that all other stamps with stacks of pictures act as if their single pictures were frame items of an image with one frame.

Heading mode images

If you are using an image of the Heading mode type as a stamp, Natural Art receives complete information from the image itself about how the different headings should be displayed. Therefore, the following happens:

• If you select a stamp and repeatedly click on the paper, the frame items of its first frame will be printed in turn. (In fact, the frame items of a different frame may be used if you have already drawn with that stamp, see below – the most recently used frame will be used again.)

• If you select a stamp and draw with it, the frame corresponding to the heading of the pointer movement will be selected and its frame items will be printed on the paper in turn.

For example, if you select an image like the robot with 4 frames and a zero angle of 20, its first frame will be used whenever your pointer moves within the range -25 to 65 degrees, its second frame will be used for headings in the range 65 and 155 etc.
Working with a single picture

The spacing used between each successive pair of printed frame items will correspond to the current **Space** setting, see the section on **Drawing with a stamp**.

Note that:

- The strategy specified above corresponds to the way in which animated shapes are used and displayed in **Imagine**.

- Note that when you use an **image** of the **Heading** mode type as a stamp, Natural Art does not **rotate** any frame items – it assumes that the frames themselves already express the appropriate rotations.

- Suppose that the image that you use as a stamp has only one frame. Then for all headings of the drawing the same frame is used and its frame items are cycled through, always in its original heading (i.e. no picture is rotated).
• Suppose that each frame of the image that you use as a stamp has only one frame item. Whenever you click on the picture its first frame is printed. Whenever you draw with this stamp, the frame that corresponds to the current heading of the movement is repeatedly printed.

Frame mode images

If you are using an image of the Frame mode type as a stamp, Natural Art receives no information from the image itself about how the different headings should be displayed. Therefore it rotates the frame items of the image to express the different headings of the pointer movements and the following happens:

• If you draw and your stroke is more or less horizontal (from left or right), all the frame items of all the frames are printed in turn in a rough row with no or nearly no rotation. If your stroke is more or less vertical (from top or bottom), all the frame items of all the frames are printed in turn in a rough column with no or nearly no rotation. (To illustrate this, we used the same robot, see overleaf, with the Heading mode changed to Frame mode.)
If your stroke starts roughly horizontally but then bends upwards or downwards (and continues in that direction), all the frame items of all the frames are printed in turn, perpendicular to your movement. That is, the frame items are rotated by Natural Art according to the current movement of the pointer, see the left part of the figure below.

If your stroke starts roughly vertically upwards, but then bends and continues in that direction, all the frame items of all the frames are printed in turn in the direction of the movement. That is, they are rotated to express the heading of the movement.

If your stroke starts roughly vertically downwards, but then bends and continues in that direction, all the frame items of all the frames are printed in turn in the opposite direction to the movement.
You can modify the spacing between successive pairs of prints by setting the Space to a different value (including a random value), see the section on Drawing with a stamp.

If you tick the Paint->Stamp->Shuffle option, the order of the frame items printed on your picture will be random, see the description of the Stamps control menu.
Stamps control menu

If you choose the **Paint->Stamp** option, the following submenu will open:

![Stamps control menu screenshot](image)

**Random spacing**  Toggles the random spacing between pairs of successive prints of a stamp on/off. Random spacing is only used when you draw with a stamp. Compare the following queues of robots. The second one has random spacing.

![Robots queue comparison](image)

Note that if **Random spacing** is on, the current value of the **Space** setting is used as the average value and all inserted spaces are between 0 and double that value, see the section on **Drawing with a stamp**.
Shuffle

If you draw with a stamp that is a stack of pictures, all the frame items are printed in turn in their natural order. By ticking the Paint->Stamp->Shuffle option, however, all frame items are printed in a random order (until you switch this option off).

Use as Selection

Places the currently selected stamp in the centre of the paper, surrounded by the selection marks and rectangle, so that before printing it on the picture, you can resize it, rotate it or process it like any other selection.

Use as Background

Opens a submenu containing four styles (Centre, Fit, Resize and Tile) specifying how the current stamp should become the background of the paper. This is identical to the Layout option of the Paper Properties dialogue box.
Stamps and the graphics tablet

If you work with a graphics pen and tablet and draw with a stamp which is an image with several frames and frame items, Natural Art will respond to the pressure you place on the pen. The pressure controls the level of transparency of each frame item printed.

With the help of this feature you can create many interesting effects, like a countryside slowly emerging from a mist.

Adding your own stamps

If you want to use a different picture (of any size and supported file format) as a stamp, copy it into the Stamps folder of Natural Art (ideally into a subfolder that corresponds with the theme of your picture). Then, when you open that theme in the Stamp Browser, your stamp will be available, alongside the other stamps, ready to be used.

Sometimes you may want to quickly (and repeatedly) create a group of several randomly organized things or characters out of the single stamps you have found in the Stamp Browser. You can use Natural Art to create one image out of these single stamps, save it into the Stamps folder, possibly tick Random spacing and Shuffle and use it as a compound stamp with a stack of pictures.
4.10 Applying painting effects

What are painting effects?

Think about painting effects as if they were extra brushes for special effects. They specify the way in which the pixels of the picture that you pass through when drawing freehand, using shapes, adding text etc. should be modified. For example, if you select erasing and you draw a rectangle, you will erase a rectangle from your picture.

If any effect, other than erasing, has just been used, then dragging with the right button (of the mouse or pen) will erase with the current settings. Note also that you can obtain very interesting results if you combine various painting effects with textures and motifs – experiment with such combinations on your own.

If you are using a painting effect, the following settings will determine the result:

- Which painting effect you have selected.
- What nib size is selected.
- Which nib shape is selected.
- What level of transparency is set.
- If anti-aliasing is on or off.
- Which shape you are going to add to your picture with the selected painting effect.
- What text you are you going to add to your picture; what the text settings are.
- If you are going to fill or replace colour.
- If any texture is set.
- If any motif is set.
- If any level of symmetry is set.
List of painting effects

To select a painting effect:

1. Click on its button on the Painting Effect toolbar or choose the Brush->Effect option from the Paint menu and choose an option from the list.

The painting effects available are:

- Basic drawing
- Erasing
- Colouring
- Smearing
- Lightening
- Darkening
- Softening
- Sharpening
- Highlighting edges
Basic drawing

Use **basic drawing** to add simple dots, lines or shapes without any artistic effect of **brushes**.

Note that:

- Basic drawing uses the currently selected colour and its transparency.
- If you apply basic drawing using a pressure-sensitive graphics tablet, you will not obtain varying thicknesses by changing the pressure on the pen. However, you will obtain different densities of colour.
- The colour density of a line drawn using basic drawing does not increase even for repetitive strokes.

Basic drawing can be, for example, used to add clear and easily visible technical information into a photograph. In the right part, the same lines were added using white and black artistic pencils. You can see that both colours were combined with the pixels behind them and thus lost their density.
Erasing

Use **erasing** if you want to remove (partly or completely) certain parts of your picture. Note that:

- The eraser ignores the currently selected colour.
- You can influence the **efficiency of erasing** by setting different transparency levels. The lower the current level of transparency set on the **Transparency slider**, the greater the erasing of the pixels being passed through. If the transparency slider is set to **0**, each erased pixel will immediately lose all of its colour and will become a transparent pixel.
- If you erase using a pressure-sensitive graphics tablet, you will obtain different levels of transparency by changing the pressure on the pen.
- If you erase using a **selection**, the amount of erasing of each pixel is specified by the level of transparency of the corresponding point in the selection. The lower it is, the greater the erasing will be. The same is true if you erase by adding a filled shape (like a filled circle etc.) and you have selected a **motif**. The same also applies if you erase when a **texture** is selected.
- If you have specified a background picture or background colour for the paper and you erase, you will reveal the corresponding parts of the background picture or background colour.

Erasing allows you to create some spectacular visual effects.
Colouring

Use **colouring** if you want to modify the colour range of your picture or certain parts of it.

Note that:

- Colouring uses the currently selected colour to re-paint each pixel of the picture that you pass through.

- You can influence the **intensity of colouring** by setting different **transparency levels**. The lower the current level of transparency set on the Transparency slider, the greater the colouring of the pixels being passed through.

- If you apply colouring using a pressure-sensitive graphics tablet, you will obtain different intensities of colouring by changing the pressure on the pen.

The first instance shows the original photograph.
The window is then coloured using a yellow filled polygon with a transparency level of 0.
The third instance shows the result.
The fourth instance starts with the original picture once more and is coloured using the same yellow filled polygon with a transparency level of 165.
The fifth instance shows the result.
Smearing

Use **smearing** if you want to blur or smear certain parts of your picture.

Note that:

- Smearing ignores the currently selected colour.
- You can influence the **range of blur** by setting different **transparency levels**. The lower the current level of transparency set on the Transparency slider, the longer the range of blurring of the pixels being passed through.
- If you apply smearing using a pressure-sensitive graphics tablet, you can obtain different widths and ranges of blur by changing the pressure on the pen.
- If you smear using a filled shape (like a filled circle etc.), the resulting effect will be similar to **softening**.

It is worth trying to smear with high nib sizes, like 10 or even more, combined with different levels of transparency.

The first instance shows the original photograph.
Then the smearing effect was selected and applied with freehand drawing, nib size 12, to the reflection in the water to blur it considerably.
Lightening

Use **lightening** if you want to lighten certain parts of your picture.

Note that:

- Lightening ignores the currently selected colour.
- You can influence the **degree of lightening** by setting different **transparency levels**. The lower the current level of transparency set on the Transparency slider, the greater the lightening of the pixels being passed through.
- If you apply lightening using a pressure-sensitive graphics tablet, you can obtain different degrees of lightening by changing the pressure on the pen.
- Lightening performs the opposite modification to your picture to **darkening**.
- Lightening is a useful tool for correcting dark photographs. Set the level of transparency to a very high value and repeatedly cover the picture (or part of it) using a filled rectangle, ellipse, polygon etc.

Darkening

Use **darkening** if you want to darken certain parts of your picture.

Note that:

- Darkening ignores the currently selected colour.
- You can influence the **degree of darkening** by setting different **transparency levels**. The lower the current level of transparency set on the Transparency slider, the greater the darkening of the pixels being passed through.
- If you apply darkening using a pressure-sensitive graphics tablet, you can obtain different degrees of darkening by changing the pressure on the pen.
- Darkening performs the opposite modification to your picture to **lightening**.
Softening

Use **softening** if you want to soften colour transitions or sharp borders within your picture.

Note that:

- Softening ignores the currently selected colour.
- You can influence the **degree of softening** by setting different **transparency levels**. The lower the current level of transparency set on the Transparency slider, the greater the softening of the pixels being passed through.
- If you apply softening using a pressure-sensitive graphics tablet, you can obtain different degrees of softening by changing the pressure on the pen.
- Softening performs the opposite modification to your picture to **sharpening**.
Sharpening

Use **sharpening** if you want to stress borders between colour tones.

Note that:

- Sharpening ignores the currently selected colour.
- You can influence the **degree of sharpening** by setting different **transparency levels**. The lower the current level of transparency set on the Transparency slider, the greater the sharpening of the pixels being passed through.
- If you apply sharpening using a pressure-sensitive graphics tablet, you can obtain different degrees of this effect by changing the pressure on the pen.
- Sharpening performs the opposite modification to your picture to **softening**.

The first instance shows the original photograph.
The sharpening effect is selected and a tower is covered by a yellow filled polygon with a transparency level of 125.
The third instance shows the result.
The fourth instance starts from the original picture and uses the same polygon with transparency level of 40.
The fifth instance shows the result.
Highlighting edges

Use **highlighting edges** if you want to colour and highlight the outline of your picture.

Note that:

- Highlighting edges uses the currently selected colour; it affects all pixels being passed through, which are not themselves transparent but are neighbours of one or more transparent pixels. They are coloured by the currently selected colour.

- You can influence the **degree of highlighting edges** by setting different **transparency levels**. The lower the current level of transparency set on the Transparency slider, the greater the highlighting of the outline pixels being passed through.

- If you apply highlighting edges using a pressure-sensitive graphics tablet, you can obtain different degrees of this effect by changing the pressure on the pen.

Note also that this special effect is really helpful when you need to blacken and emphasize the outline of an animated figure.
4.11 Anti-aliasing

Anti-aliasing is a smart way of softening free-hand strokes, lines, regular shapes, edges of letters etc. by adding extra pixels in various transparency levels of the currently selected colour.

To toggle anti-aliasing on and off:

1. Click on the Anti-aliasing button of the Main toolbar.

By default, this mechanism is on. You are recommended to always use this feature unless you explicitly need to have sharp outer edges for your pictures.

The following activities are influenced by anti-aliasing:

- **Adding shapes** (like freehand drawing, lines, circles, rectangles etc.). The first row of the picture above shows a pair of circles, the left one was drawn with anti-aliasing on, the right one with anti-aliasing off.

- **Filling areas.** The second row of circles was filled with anti-aliasing off, the third pair of circles was filled with anti-aliasing on.

- **Adding text.**

- Resizing, rotating or skewing a selection.
Working with a single picture

The picture below shows several pairs of objects (selections, letters, ellipses and lines). In each pair, the first object was created with anti-aliasing on, the second one with anti-aliasing off. The pair of pots illustrates the results obtained when resizing (or rotating, slanting, distorting) a selection with and without anti-aliasing. The pair of letters illustrates the difference by zooming in so that all details are easily visible. The last group shows how the visual effect of anti-aliasing depends on the brush used. Black ellipses with lines were drawn using the felt pen and any difference is hardly visible. The blue ellipses and lines were drawn using the watercolour brush and the effect of anti-aliasing is obvious.
4.12 Working with symmetry

Many characters and objects around us are symmetrical in one way or another. If you make use of any type of symmetrical drawing in Natural Art, you will extend and enrich your set of creative tools. Natural Art provides you with horizontal symmetry and vertical symmetry and their combination. Use the following buttons (or options):

**Horizontal and Vertical Symmetry On/Off**
Click on this button on the **Main** toolbar or choose the **Paint->Symmetry->Horizontal and Vertical** option. It turns both horizontal and vertical symmetries on or off, see below.

**Horizontal Symmetry On/Off**
Click on this button on the **Main** toolbar or choose the **Paint->Symmetry->Horizontal** option. It turns horizontal symmetry on or off. When turned on, a horizontal guideline appears in the middle of your picture (or elsewhere if you had already used it before and moved the guideline to another position, see **Symmetry Set-up** below). The guideline highlights the position of an imaginary horizontal mirror, which reflects your next steps when painting, drawing, adding shapes, stamping etc.

**Vertical Symmetry On/Off**
Click on this button on the **Main** toolbar or choose the **Paint->Symmetry->Vertical** option. It turns vertical symmetry on or off. When turned on, a vertical guideline appears in the middle of your picture (or elsewhere if you had already used it before and moved the guideline to another position, see **Symmetry Set-up** below). The guideline highlights the
position of an imaginary vertical mirror, which reflects your next steps when painting, drawing, adding shapes, stamping etc.

Symmetry Set-up

Click on this button on the Main toolbar. It allows you to change the position of the symmetry guidelines. If any of the three symmetries is active and you click on the Symmetry Set-up button, your pointer will change into a crosshair, which allows you to drag the guideline or guidelines to any position on your picture. If only horizontal or vertical symmetry is active, you can drag only one guideline. If both horizontal and vertical symmetries are active, you always drag the spot where the guidelines meet. This allows you to specify a new position for the horizontal and/or vertical mirrors that reflect the next steps you perform to your picture. As soon as you stop dragging one or both guidelines, the Symmetry Set-up tool is automatically turned off.

Note that only one of the three symmetry tools (horizontal, vertical or both) can be switched on. To disable the Symmetrical Painting mode, click on the corresponding button again or choose None from the Paint -> Symmetry menu.
Note also that the **Symmetrical Painting** mode influences:

- **Adding shapes** (including freehand drawing), **adding text, filling and colour replacing**. Be aware that every stroke or other action you make to your painting appears in your picture in a **mirrored way**, including adding text.
- Putting **stamps** on the page.
- Applying any **painting effect**, like basic drawing or erasing or smearing.

Note also that you can create many interesting pictures by successively turning symmetries on and off, applying different guideline positions, stamping with / then without / then with symmetry again, switching from one type of symmetry to another etc. The pictures overleaf were created using these methods.
Working with a single picture

In this picture, horizontal and vertical symmetry were used in four different positions, each time for creating the frame of a postage stamp. Then they were filled with different colours (without any symmetry) and had text and stamps added.

In this picture the background was prepared, then horizontal symmetry used for stamping a sequence of characters in one stroke, see the section on Drawing with stamps with stacks of pictures. Then the reflected row of characters was selected and slanted slightly to the right. Finally the reflection in the water was blurred by drawing over it with a light blue watercolour.
4.13 Selecting items

Use this mode to select a rectangle and apply one or several operations to it.

Selection mode

To toggle Selection mode on/off:

1. Click on the Selection button of the Main toolbar, or choose the Paint->Selection->Define Selection option.

In Selection mode, the cursor changes and you can specify a selection by dragging a rectangle (see the left part of the picture below).

When a selection rectangle has been defined (see the middle part of the picture below), you can do the following:

- Before you move the selected area from its original position, you can re-define the borders and position of the selection rectangle (i.e. the border itself, not the contents of the rectangle). Hold down the Shift key (the selection rectangle then changes slightly, see the right part of the picture). Now you can either drag any of the eight square marks to resize the rectangle, or drag the border or interior of the rectangle to move the rectangle around the picture.
Working with a single picture

- (Without holding down the **Shift** key) drag the current contents of the selection rectangle to another position (see the left part of the picture below). You can do this either directly using the mouse or pen or by using the arrow keys on the keyboard.

- (Whilst holding down the **Ctrl** key) drag a copy of the current contents of the selection rectangle to another position on the paper and stamp it there.

- Drag any of the eight square marks (without any other key) to **resize** (i.e. stretch) the current contents of the selected rectangle (see the middle part of the picture below).

- Double-click inside the selection rectangle to replace the eight square marks by **four circles** (see the right part of the picture below) which can be dragged to **rotate** the current contents of the selection.

- Double-click inside the selection rectangle twice to replace the eight square marks by **eight diamonds** (see the first part of the picture below). Drag any of the four diamonds on the sides of the selection rectangle to **skew** the area (see the left part of the picture below). Drag any of the four diamonds on the corners to **distort** (i.e. stretch and bend) the current contents of the selection (see the middle and right parts of the picture below). Note that the selection rectangle transforms into a trapezoid.
• Repeatedly double-click inside the selection area to cycle through resizing / rotating / distorting or skewing the selection. Note that applying multiple transformations to the selected picture may yield very interesting variations of the same object, see the picture below.

• Right click inside the selection rectangle and choose the Restore to Original option if you want to remove all the transformations you have applied to this selection.

• Press Escape to de-select the selection rectangle.
Working with a single picture

**Selection menu**

If you choose the **Paint->Selection** option or if you right click on the selection rectangle, a submenu with the following options opens:

- **Define Selection**
  Performs the same action as clicking the **Selection** button using the left mouse button, i.e. **Selection** mode is toggled on/off. In **Selection** mode, the cursor changes and you can specify a selection by dragging a rectangle.

- **Load Selection…**
  Opens the **Open** dialogue box, which allows you to open and process any picture of a **supported file format**.

- **Save Selection As…**
  Opens the **Save As** dialogue box, which allows you to specify the name of a file and its format for saving the current contents of the selection rectangle.

- **Transparent**
  If this option is on, each transparent part of the selection will be transparent when being moved with the selection rectangle. Otherwise, it will not be transparent.
Working with a single picture

- **Restore to Original**: After you apply any of the operations available for selections, the **Restore to Original** option becomes available. Selecting this removes all transformations applied to the currently selected rectangle. However, it can only be used whilst the area is still selected. (Later, you can use the **Undo** option to clear any sequence of transformations step by step.)

- **Resize**
- **Rotate**
- **Skew**: These options allow you to resize, rotate and skew the current contents of the selection rectangle.

- **Transform**: Opens a submenu offering the basic options of:
  - **Flip Horizontally** or **Flip Vertically**.
  - **Stretch to 50%** or **Expand to 200%**.
  - **Rotate 90°**, **Rotate 180°** or **Rotate 270°**.

- **Paint With Selection**: Defines the current contents of the selection rectangle as a **custom nib for drawing**.

- **Use as Background**: Opens a submenu with four styles (**Centre**, **Fit**, **Resize** and **Tile**) specifying how the current selection should become the background of the paper.

- **Add As Frame Item**: Copies the contents of the selection and adds it as a new **frame item** to the current frame. (You will see this if you have the **Organizer** window displayed.)
4.14 Zooming

It is very useful to be able to zoom in or out on parts of the picture you are currently working with. It helps you in fine tuning the details, selecting a region more precisely or moving with individual pixel precision etc. If no zoom is applied, the picture is displayed at **Normal Size**, i.e. 100% (note that in **Preview** mode you always see the picture at normal size, neither zoomed in nor out).

To change the level of zoom:

1. Either:
   - Roll the wheel of your mouse to zoom in or zoom out, or
   - Press the keyboard shortcuts **Ctrl+Q** and **Ctrl+W** (or alternatively **Ctrl+Num -**, **Ctrl+Num +** and **Ctrl+Num ***), or
   - Click on the **Toggle Zoom->Normal Size** button of the **Main** toolbar, or
   - Choose the option in the **View->Zoom** submenu.

If you want to find out what the current level of zoom is:

1. Either:
   - Have a look at the title bar of the Natural Art main window, or
   - Open the **Zoom Settings** window (**F8**) and check there.
Note also that in the **Zoom Settings** window there is a thumbnail view of the whole picture with a **highlighted area** that represents the area that is currently enlarged in the working area. This highlighted rectangle can be dragged using the left mouse button or the pen within the whole thumbnail for quick and easy navigation.

For further details see the description of the **Zoom Settings** window.
Working with a single picture
5 Working with images: animations

Natural Art is a powerful tool for creating stand-alone pictures to be printed, stored or displayed, or pictures to be used in other programs. In addition, it lets you create or modify images, i.e. animated pieces of graphics like:

- Animated GIFs for Web pages.
- Animated cursors for Windows.
- Images for Imagine to be used as the shapes of its turtles.
- Complex stamps for Natural Art itself.
5.1 Images and their properties

RNA images (and also Imagine LGFs, animated GIFs, animated cursors or LGW SuperLogo images) are complex graphical data objects that are mainly used as animated pictures, complex stamps for Natural Art itself or shapes for Imagine turtles etc. Each image is an empty or non-empty series of frames.

Each frame consists of either a single picture or a stack of pictures called frame items. A stack of pictures forms a kind of animation film that illustrates, for example, the movement of a certain character in a certain direction. Thus, different frames may illustrate the movements of the same character in different directions (like walking to the right, walking towards us, walking to the left and walking away from us).

The picture below illustrates the robot RNA file (you can see its name immediately below the caption of the Organizer window). In the left-hand part of the Organizer (the compass) you can see that the robot image consists of four frames: each of them represents a possible heading of the robot within 90 degrees (i.e. a quarter of a circle). The first frame will be used to display any heading of the robot between 335 and 65 degrees (or in other words between $-25^\circ$ and $65^\circ$). Currently, the first frame is selected and its six frame items, together with their corresponding time delays, are displayed in the right-hand part of the Organizer.

Note that images can have:

- Several frames used to display different headings, with each frame consisting of only one frame item. When you use such an image as a turtle's shape, the turtle is not animated. However it displays its current heading. The Imagine default green turtle is an example of such an image.
• Only one frame consisting of several frame items. When you use such an image as a turtle's shape, the turtle does not display different headings. However, its GIF-like animation is run automatically by Imagine. For further details see the section on the Organizer.

• Several frames, where each frame may consist of several frame items. Such images are typically used for displaying an animated turtle that alters its shape depending on its current heading.

Images are used in Imagine projects. In addition to its own graphical contents, each image has additional information attached to it:

• **HotSpot** for each frame item.
• **Time delay** for each frame item.
• **Heading mode** or **Frame mode**.
• **Zero angle**.
• **Animation loop** (yes or no).

**HotSpots**

A **HotSpot** is a point set within each **frame item**. This point is recognised by several Imagine image commands and behaves as the reference point of the frame item. For example, if an **image** is used as the Imagine turtle's shape, the **HotSpot** of the image (of the frame and frame item currently displayed) is used as the turtle's current position.
Note also that:

- Each frame item of an image has its own HotSpot.
- The upper left-hand corner of the frame item is referred to as point \([0 0]\). The \(X\) co-ordinate increases to the right, the \(Y\) co-ordinate increases downwards.
- The hot stop does not have to be located inside the frame item. If the size of a frame is, for example, \([53 30]\), its HotSpot may be at position \([110 20]\) or \([-25 -10]\) etc.

The location of the frame item's **HotSpot** is displayed in the **Show and Specify HotSpot** view. To turn on this view:

1. Click on the **Show and Specify HotSpot** button of the **Animation** toolbar or press **F11** or choose the **View->Show and Specify HotSpot** option.

If you turn on this view, the current **HotSpot** of a frame item is marked by a white cross. In addition, the mouse cursor is changed into four white arrows, which make it easy to specify another position (even outside of the picture or paper) for the **HotSpot**.

![Image of a HotSpot](image_1)

The other method of specifying the **HotSpot** position is to use the **HotSpot** dialogue box.

**Delays**

Each **frame item** of an **image** has a time delay attached to it. If you use this image as a turtle's shape, Imagine will automatically display all the frame items of the current frame one by one. It will use these time delays to control the speed at which the frame items are changed within this **animation loop**. A time delay of **1000** corresponds to **1** second. Thus, the mechanism of automatic animation is achieved.
To change the time delay of a single frame item:

1. Click on the current time delay and edit it, or right click on the frame item and choose the Animation->Set Delay… option to open the Delay dialogue box.

For details see the section on the Organizer.

![Delay dialogue box](image)

To change all the time delays of all the frame items of a frame to one new value:

1. Right click on that frame in the Frame Organizer.
2. Choose the Animation->Set Delay… option.
   
   The Delay dialogue box opens.

To change all the time delays of all frame items of all frames of an image:

1. Choose the Animation->Set Delay… option or right click on the image in the Image Organizer and choose the Animation->Set delay… option.
   
   The Delay dialogue box opens.

**Heading mode or Frame mode**

An image may consist of several frames and contain information about how these frames are intended to be used in Imagine. There are two options:

- In Heading mode, frames are automatically used by Imagine to indicate the turtle's current heading.
- In Frame mode, frames are not related to the turtle's heading. You have to decide which frame should currently be used by a turtle as its shape yourself.
When you attach an image to a turtle, the turtle's Frame mode setting is automatically set to true or false depending on whether the image is in Frame mode or Heading mode.

To change an image from Frame mode to Heading mode or vice versa:

1. Choose the Animation->Frames option.
2. Either tick or clear the Heading Mode option
(Or do the same in the Frame Organizer menu.)

Zero angle

Each image in Heading mode has as an angle specified, which is called the zero angle of that image. Its value specifies the axis of the first frame of the input image. The default value is 0 degrees, i.e. North. However it is sometimes sensible to modify this default value. The example below illustrates the robot shape, which has four frames. The first of them shows the robot walking away from us. The zero angle of this image is 20°.

In this case, it makes sense to divide the possible headings into the four groups: from -25° to 65°, from 65° to 155°, from 155° to 245°, and from 245° to 335°, i.e. -25°.
To change the zero angle of an image:

1. Choose the **Animation->Frames->Set Zero Angle...** option or click on the current setting in the middle of the compass part of the **Organizer**, whilst that image is displayed.

**Animation loops**

If the **animation loop** of an **image** is set to true and you use it as an Imagine turtle's shape, the frame items of each frame of that image will be displayed repeatedly, in an animation loop. Otherwise the sequence (animation film) will be displayed just once.

To switch the animation loop of an image on or off:

1. Choose the **Animation->Frames** option.
2. Either tick or clear the **Loop Frames** option.

(Or do the same in the **Frame Organizer** menu.)

**HotSpot dialogue box**

To open this dialogue box you can either:

- Choose the **Animation->Set HotSpot...** option in the main menu bar.
- Press **Ctrl+H**.
- Choose the **Animation->Set HotSpot...** option from the **Image Organizer** menu, if you want to set the same HotSpot for all frame items of all frames of that image.
- Choose the **Animation->Set HotSpot...** option from the **Frame Organizer** menu, if you want to set the same HotSpot for all frame items of that frame.
- Choose the **Animation->Set HotSpot...** option from the **Frame Item Organizer** menu, if you want to set the HotSpot for that particular frame item.
The dialogue box allows you to specify a new **HotSpot** for one or many **frame items** (depending on what was selected at the time that you opened the dialogue box).

The dialogue box offers three ways of specifying the **HotSpot**:

- Use the **HotSpot X** and **HotSpot Y** edit boxes to specify its position as a percentage of the width and height of the frame item. For example:

  These HotSpots were set using:
  
  - **50%** and **50%** (the HotSpot is in the middle of the frame item).
  - **50%** and **100%** (the HotSpot is in the middle of the bottom edge).
  - **20%** and **110%** (the y co-ordinate is outside the picture).
  - **-30%** and **50%** (the x co-ordinate is outside the picture).

- Use the **HotSpot X** and **HotSpot Y** edit boxes to specify its position in pixels, for example **20** and **10**, or **0** and **0**, or **-10** and **50**.

- Use the **Quick select view** in the dialogue box. If you click on any of the nine buttons, the HotSpot is placed in the corresponding position.
Note that using percentages for specifying the **HotSpot** position is very useful in situations when you do it in parallel for many frame items of different sizes. Note also that sometimes, especially when you develop or scan an animated image, it is necessary to specify the **HotSpot** manually frame item by frame item until you manage to create a realistic and convincing illusion of movement.

**Transform dialogue box**

This dialogue box helps you to transform a **frame item** (or several frame items) by resizing, rotating and/or flipping it. Each combination of these operations may be applied to all the selected frame items in one step. The whole transformation is usually (but need not be) supplemented by the **anti-aliasing** mechanism.

To open the **Transform** dialogue box:

1. Select one or several frame items or several **frames** or even the whole **image** by clicking on its tab in the **Organizer** window.
2. Either:
   - Choose the **Animation->Transform…** option, or
   - Press **Alt+T**, or
Working with images: animations

- Right click on the selected frame item/items or frames or the image and choose the Animation->Transform... option from the menu that appears.

**Resize**

The **Resize** operation's input is expressed either:

- As a percentage of the original size (such as 33%, 50%, 150% etc.).
- In plain numbers such as 40 or 230 which specify the exact width and height of the resized image in pixels.

Each of these values can be set either to one of the pre-specified values in the drop down list, or entered as any positive integer or percentage. Note that below the **Height** edit box there is the **Proportional** tick box that preserves the ratio between the height and width of the picture. If you clear this option, two numbers (or percentages) can be set separately.

**Rotate**

The **Rotate** operation's input is an angle (in degrees) by which the picture should be rotated in a clockwise direction. You may, however, choose or type in a negative angle to turn it anti-clockwise.

**Flip**

The **Flip** operation allows you to choose to have the picture flipped horizontally and/or vertically in parallel to resize and/or rotate it.

In the **Transform** dialogue box you can specify any combination of these operations. When you finally click on **OK**, the compound transformation is applied to each selected frame item and the original item is replaced by the result. Note that these operations can be undone using the **Undo** button.
The example shown below demonstrates the use of resize to 200% and rotate by 90 degrees. Both frame items were rotated and resized.

**Generate dialogue box**

This is similar to the Transform dialogue box, i.e. it can also apply resizing, rotating and flipping supplemented by anti-aliasing. The main difference is that the Transform dialogue box modifies and rewrites a frame item or several items, whereas the Generate dialogue box keeps the original frame item/items and produces one or several additional ones (the number is specified in the Count box).

Note that in this process it may happen (depending on your current settings of the values in the dialogue box) that for each frame item you generate a sequence of new items that contain the original frame item once again. For example, the new items may contain the original frame as the last item of the sequence. In some cases you need to keep it there, in others you need to delete it. This is illustrated in the following examples. In each of these, there is one frame item of a bee, and this is selected when the Generate dialogue box is opened.
Example 1

The settings are **Count = 8, Angle = 360** and anti-aliasing is on. This means that from the chosen frame item a further 8 new frame items are generated and these gradually rotate to the right in such a way that the last frame item is rotated by **360** degrees. Thus, the first new item is rotated by **45**, the second by **90**… etc.

Because the only operation applied is a rotation (without resizing or flipping), the last new item generated is identical to the first one and so it should be deleted.

---

Example 2

This uses all the previous settings with the addition of **Resize** to **10%**. This means that the sequence is evenly resized in such a way that the last one is **10%** of the first. Now, obviously, the last one generated is not identical to the first one.
Example 3

This time the settings are **Count = 8**, no **Resize**, i.e. **Width** and **Height = 100%**, no **Rotation**, **Flip Vertically**. The result is a sequence of 8 new items which gradually flip vertically back to the original size of **100%**.

The **Generate** dialogue box is, however, an even more powerful tool. So far, all examples have worked in the **Frame Item Organizer** only, always starting with one frame item there. Consider a situation in which you have an animation sequence in the **Organizer**, for example the bee again, and the whole frame is selected. The settings in this example are **Count = 12**, **Rotate = 360**, anti-aliasing is on. The result is 12 animated rotations i.e. frames, each of which contains the same number of frame items as the original, all of which are rotated in the same way.
5.2 The Organizer

Organizer window overview

This is the central organizing panel of Natural Art whenever you work with several pictures or whenever you work with stacks of pictures (in particular RNA images, but also Imagine LGF files, animated GIF files, animated icons etc.). It helps you to organize all the images currently open. Within a selected image it helps you to organize all its frames. Within a selected frame, it helps you to organize all its frame items.

The Organizer is a window that may be completely hidden, completely shown or minimized. If it is not hidden, it can be either docked (usually to the bottom edge of the main window) or floating, in which case you can place it at any convenient position on the screen:

- If the Organizer is completely hidden, press F4 or choose the View->Organizer option to display it.
- If it is minimized, click on the small open mark on its title bar.
- If it is visible, click on the cross mark in its title bar to hide it completely or click on the triangle to minimize it.
- If the Organizer is docked, you can click on its title bar and drag it to position the window anywhere within the screen.
The Organizer window has three parts, as shown in the figure below:

- The **Image Organizer** for organizing images.
- The **Frame Organizer** for organizing frames.
- The **Frame Item Organizer** for organizing frame items.

![Image Organizer Diagram](image.png)

The appearance and behaviour of these depend on which has the `focus`, i.e. which area has been clicked in and is therefore active, and also whether one or several images are currently selected.

Within the Organizer you can modify the order of images on your desktop, the order of frames in an image and also the order of frame items in a frame. In addition, you can apply several operations and transformations to one or several items (either images, frames or frame items).

Also, you may specify the **animation loop**, **heading mode**, **zero angle** and some other general properties of each image. Or you can simply select an image, select one of its frames, select one of its frame items, and thus have it displayed on the page in order to work on it.
Organizing images

In Natural Art, you can open several images (of any accepted file format) and put them on your desktop. Then, you can copy some parts of one into another, modify several images in the same way or even apply some complex operations to all frame items of those images in parallel.

Each image that you open is represented by its own tab in the upper part of the Organizer. The tab contains the name of the file.

Note for advanced users: Each RNA image file may contain more than one image stored inside it. If you open one of these files, each image will get its own separate tab (with number suffix, see below) and they will immediately cease to be connected together. To save several images into one file, you have to select all of them and choose the Save As option from the Image Organizer menu.
Image Organizer menu

When you right click on a tab corresponding to an image in the Image Organizer, the following menu opens:

This allows you to:

<table>
<thead>
<tr>
<th>Option</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Ctrl+N</td>
<td>This is identical to the File-&gt;New option.</td>
</tr>
<tr>
<td>Open…</td>
<td>Ctrl+O</td>
<td>This is identical to the File-&gt;Open… option.</td>
</tr>
<tr>
<td>Save</td>
<td>Ctrl+S</td>
<td>This is identical to the File-&gt;Save option.</td>
</tr>
<tr>
<td>Save As…</td>
<td>Alt+F2</td>
<td>This is identical to the File-&gt;Save As… option.</td>
</tr>
<tr>
<td>Close</td>
<td>Ctrl+F4</td>
<td>This is identical to the File-&gt;Close option.</td>
</tr>
<tr>
<td>Edit</td>
<td></td>
<td>The Edit submenu is similar to the Edit submenu</td>
</tr>
<tr>
<td></td>
<td></td>
<td>covered in the Frame Organizer section. The only</td>
</tr>
<tr>
<td></td>
<td></td>
<td>difference is that this menu affects the whole</td>
</tr>
<tr>
<td></td>
<td></td>
<td>image.</td>
</tr>
</tbody>
</table>

If you choose the Select All option here, all tabs will be selected.
If you Copy an image here, you can:

- Paste it in the **Image Organizer** area, which means that a new tab (or tabs) is created containing an exact copy of selected image (or images).

- Paste it (through the **Frame Organizer** menu only) in the **Frame Organizer** area, which means that all frames of all selected images are pasted there.

- Paste it (through the **Frame Item Organizer** menu only) in the **Frame Item Organizer** area, which means that all frame items of all frames of all selected images are pasted there.

**Animation**

The **Animation** submenu is similar to the **Animation** submenu covered in the **Frame Organizer** section. The only difference is that this menu affects the whole image.

**Using the Image Organizer when a single image is selected**

In the above, one of the **images** is currently selected. Therefore, its first **frame** is selected in the **Frame Organizer** and its first **frame item** is selected in the **Frame Item Organizer**.
You can easily modify the order of images by dragging the tab somewhere else in the sequence. As you move the mouse, the potential new position of the image is highlighted by a black insertion line. As soon as you release the mouse button, the image is inserted there.

You can also **Copy** the image as a whole, then **Paste** it either in this area as a copy of the image, or in the **Frame Organizer** area (through the **Frame Organizer** menu only) in which case all the frames are inserted, or in the **Frame Item Organizer** (through the **Frame Item Organizer** menu only) in which case all frame items of all frames of the image are inserted.

### Using the Image Organizer for several images

You can select several successive **images** by clicking further tabs with the **Shift** key pressed. In this case, no **frames** are displayed in the **Frame Organizer** and no **frame items** are displayed in the **Frame Item Organizer**.

You can drag the whole group of images and thus change the order of tabs. You can select any option from the **Image Organizer** menu that appears when you right click on the tab or tabs – this applies the action to all of the selected images. If you choose the **Save** or **Save As** options, all selected images will be saved in one file.

If several images are selected and you open **Preview** mode, all of the frame items of all of the frames of those images will be displayed in turn in loops as if glued together in one long sequence of frames.
Working with images: animations

Organizing frames

The Frame Organizer is on the left-hand side of the Organizer window, below the tab (or tabs) with the name of open image (or images). If different types of images are currently open in the Image Organizer, the current contents of the Frame Organizer depend on which image is currently selected and what type of image it is:

- If it is a photograph, a background or any kind of single picture, you should see a single line in the Frame Organizer.
- If it is an image in Heading mode with several frames, you will see a 'compass' divided into several sections.
- If it is an image in Frame mode with several frames or any other animated picture, you will see a list of frame names with small icons.
- If several images are currently selected in the Image Organizer, the Frame Organizer will be empty.

In the above example the first selection is a single bitmap photograph, the second is an image containing four frames in Frame mode, the third is an image consisting of six frames in Frame mode, and the last is a selection of two images.
Frame Organizer menu

When you right click on any frame name or compass section in the Frame Organizer, the following menu opens:

This allows you to:

**Loop Frames**  
Turns the animation loop of the whole (currently selected) image on or off.

**Heading Mode**  
Turns Heading mode for the whole (currently selected) image on or off i.e. changes into Frame mode or back.

**Set Zero Angle**...  
Makes it possible to specify a zero angle for the whole (currently selected) image.

**Convert All to Frame Items**  
Converts all frame items of all frames of this image into a single frame containing all the frame items as a long sequence.
Working with images: animations

**Edit**   Changes the structure of the image, i.e. modifies the sequence of frames by selecting options from the Edit submenu. Specifically, you can:

- **Cut** the selected frame(s) and put them into the Clipboard.
- **Copy** the selected frame(s) into the Clipboard.
- **Paste Before** or **Paste After** the frame(s) from the Clipboard.
- **Insert** a new empty frame before or after the selected one.
- **Delete** the selected frame or frames.
- **Select All** frames for further operations.

**Animation** Runs a complex (multiple) operation on all frame items of the selected frame or frames by selecting options from the Animation submenu. Specifically, you can:

- Specify one number as a delay for all frame items of the selection.
- Specify the HotSpot for all frame items of the selection.
- Minimize all frame items of the selection (this corresponds to the Animation->Minimize option or the Minimize button of the Animation toolbar).
- Insert transitions (which can be thought of as 'visual averages') between each pair of successive frame items of a frame.
- Open the Generate dialogue box and apply its compound operation or operations to all frame items of the selection.
- Reverse the order of frame items in selected frames.
- Open the Transform dialogue box and apply its compound operation or operations to all frame items of the selection.
Using the Frame Organizer for Heading mode images

Currently the focus is somewhere else (the colour of the selected frame is light). The focus may be in the page or in the Frame Item Organizer etc. Here you can see that the image is set to Heading mode, exactly one frame has been selected and its frame items are displayed in the Frame Item Organizer. You can also see that the zero angle of the image is 20° (instead of the default value of 0°).

Now the focus is here – the colour of the selected frame is dark. To have the focus here, you just click on the section of the compass. If you click on the value of the zero angle, it turns into an edit box into which you can type a new value.

You can also Cut or Copy the frame (i.e. all of its frame items), then Paste it either in this area as a frame, or in the Frame Item Organizer area (through the Frame Item Organizer menu only) as frame items.

If you drag the dark blue (selected) area of the circle, you can cut the selected frame from its current position and move (insert) it into another position within the order of frames for this image. The current insertion point is highlighted by a short black line.

If you press the Shift or Ctrl or Alt key, keep it pressed and then start dragging, the whole circle will rotate. Thus you can redefine the zero angle of the image.
Several frames are currently selected and the focus is in this part of the **Organizer**. To select several successive frames, click on the first one, press **Shift** and click on the last frame of the selection. All the frames between the first and the last, moving clockwise round the circle, are selected. Selecting frames which are not adjacent is not possible.

When more than one frame is selected, the right-hand part of the **Organizer** is empty. Also, the **Paper** area is empty unless you are in the **Preview** mode.

If you drag the blue semicircle, you can cut the selected frames from their position and move (insert) them into another position within the order of the frames of this image. The current insertion point is highlighted by a short black line.

If you press the **Shift** or **Ctrl** or **Alt** key, keep it pressed and then drag the dark blue (selected) area of the circle, the whole circle rotates. Thus you can redefine the **zero angle** of the image.

Alternatively, you can **Cut** or **Copy** the whole group, then **Paste** it either into this area as frames, or into the **Frame Item Organizer** area as frame items.
To select all frames, you can either:

- Choose the **Edit->Select All** option from the **Frame Organizer** menu which appears when you right click in this part of the **Organizer**, or
- Press **Ctrl+A** (if the focus is already here), or
- Click on any frame here, press **Shift**, then click on the frame to its left (i.e. the one next to it in an anti-clockwise direction).

When more than one frame is selected, the **Frame Item Organizer** is empty. Also, the **Paper area** is empty unless you are in **Preview** mode. All operations you apply now (for example, through the right mouse menu, see above) affect all the frame items of all the frames of the image.

### Using the Frame Organizer for Frame mode images

To switch between **Heading mode** and **Frame mode**, click the right mouse button in this area and turn off **Heading Mode** in the submenu that appears, or choose the **Animation->Frames->Heading Mode** option.

In this example, one frame is selected, and its frame items can be seen in the right-hand part of the **Organizer** (in this case the selected frame has only one frame item).
You can easily modify the order of the frames by dragging the selected frame elsewhere in the sequence of frames. As you move the mouse, the potential new position of the frame is highlighted by a black insertion line. As soon as you release the mouse button, the frame is inserted here and all the frames are renamed into the new sequence Frame1, Frame2… etc.

To select more successive frames, click on the first one, press Shift and click on the last one of the selection.

To select all the frames you can either:

- Press Ctrl A (if the focus is already here), or
- Choose the Edit->Select All option from the Frame Organizer menu, which appears when you right click in this part of the Organizer, or
- Click on the first frame, press Shift and then click on the last frame.

All operations you apply now affect all the selected frames and all their frame items.

**Organizing frame items**

This part of the Organizer window helps you to manage the frame items of the currently selected frame. It displays either:

- One frame item, if the currently selected image is a single picture (a photograph, a background etc.) or if the selected frame consists of only one frame item, or
- All frame items of a frame of the selected image or animated gif file or animated cursor etc., or
- Nothing, if several images or several frames of one image are currently selected.
Note that whenever this sequence contains more than one frame item and the image is later set as a turtle's shape, the sequence of frame items is automatically played as an animation film. It is played either in an endless loop (if the animation loop setting of the image is on) or once. Also note that the sequence of the frame items belonging to a frame has no connection with the Heading mode or Frame mode of the picture.

**Frame Item Organizer menu**

When you right click on any frame item in the Frame Item Organizer, the following menu opens:
This allows you to:

**Convert All to Frames**
Regardless of how many frame items are currently selected, you can choose the Convert All to Frames option. All frame items of the selected frame are transformed into several single-item frames and replace the formerly selected frame. The Frame Item Organizer area becomes empty and the newly created frames are selected in the Frame Organizer.

**Edit**
The Edit submenu is similar to the Edit submenu covered in the Frame Organizer section. The only difference is that whilst in the Frame Organizer all options such as Cut or Paste affect the selected frames (i.e. all their frame items), here the same options affect all the currently selected frame items.

**Animation**
The Animation submenu is similar to the Animation submenu covered in the Frame Organizer section. The only difference is that whilst in the Frame Organizer all options such as Set Delay… or Minimize affect the selected frames (i.e. all their frame items), here the same options affect all the currently selected frame items.

The Edit and Animation submenus make it possible to apply complex operations and transformations to several frame items in parallel.

**Using the Frame Item Organizer when a single item is selected**

Currently one frame item is selected and the focus is located in this part of the Organizer. The zoomed frame item is displayed in the working area so that you can edit it.
You can easily modify the order of the frame items by dragging the selected item somewhere else in the sequence. As you move the mouse, the potential new position of the item is highlighted by a black insertion line. As soon as you release the mouse button, the item is inserted there.

You can also Cut or Copy this frame item, then Paste it either in this area as a frame item, or in the Frame Organizer area as a frame with one frame item (through the Frame Organizer menu only).

Below each frame item you can see its time delay. If a frame item is selected and you click on the small light blue rectangle below the item, it turns into an edit box in which you can redefine the current value.

The same can be achieved by choosing the Animation->Set Delay… option of the Frame Item Organizer menu, which appears when you right click on the frame item, or by pressing Ctrl+D. In either of these cases, a simple Delay dialogue box opens.
Using the Frame Item Organizer for several items

You can select several frame items in the Frame Item Organizer area by clicking the first of them, then pressing Shift and clicking the last of them. Alternatively, you can select all of them by choosing Edit->Select All from the Frame Item Organizer menu, which appears when you right click on the frame icon or by pressing Ctrl+A.

If more than one item is selected, the Paper area is empty. However, you can turn it into a functional Preview area.

You can modify the order of frame items by dragging the whole group within this area. You can also Cut or Copy the group of items, then Paste it either in this area as frame items, or in the Frame Organizer area as a new frame with the specified frame items (through the Frame Organizer menu only).
5.3 Preview mode

The page (working) area of the Natural Art main window is covered by either:

- The currently selected frame item of the currently edited image – either zoomed or at its normal size.
- A preview of the currently selected frame (or frames or even images). If it consists of several frame items, a kind of animated film of all its frame items (or only those that are currently selected) is played here in loops.

To swap between Painting mode and Preview mode:

1. Either:
   - Press F9, or
   - Press the Play Forward button or Play Backward button of the Animation toolbar, or
   - Choose the View->Preview option.

Whenever you switch to Preview mode, the previewed picture (or pictures) is displayed at its normal size (independent of the level of zoom that you are currently using within the page).

To learn more about Preview mode, see the sections on:

- The Animation toolbar
- Positioning the image
- Preview area menu
Positioning the image

The behaviour when clicking with the left mouse button in the Preview area is as follows:

- If you click anywhere in the Preview area using the left mouse button and immediately release it, the previewed image will jump to where you click (more precisely, the image will be moved such that its HotSpot corresponds to the position of the mouse click).
- If you click in the Preview area and drag the mouse, the image will jump to where you click and will follow the movements of the mouse cursor. Thus, you can position the image anywhere in the area.
- If you press Ctrl and drag the mouse, the image will initially jump to the position of the first click and stay there. However, a grey arrow, starting at the position of the click, will follow the mouse cursor.

When you release the mouse button, the arrow is used to specify the movement of the animated image along the screen. Its magnitude determines the speed of the image, and its direction specifies the direction of the movement. As soon as you click again, the movement is interrupted.

- If you press Ctrl and Shift and drag the mouse, the direction of the grey arrow is constrained to be a multiple of 45 degrees.
Preview area menu

If you click in the Preview area with the right mouse button, a menu opens which contains two options:

- **Background Colour…** opens a colour palette that you can use to specify the background colour of the Preview area. This allows you to see how your image would appear when placed on top of a certain colour. Note that this background colour is not part of the image and is independent of the current paper colour.

- **Background Picture…** opens the Open dialogue box that you can use to choose the file to be displayed as the background of the Preview area. If the background picture is smaller than the area, it will be centred in it. This allows you to see how your image would appear when used in Imagine or elsewhere on top of a certain background picture. Note that this background picture is not part of the image and is independent of the current paper colour.
Working with images: animations
6 Customizing Natural Art

The environment of Natural Art can be customized to fit the current needs and level of experience of its user. You can specify:

- Which options are available in the main menu and all of its submenus.
- Which **toolbars** and **tool windows** are available to the user – either standard ones or user-created ones.
- Which properties the toolbars and tool windows have (like size, position for docking or floating, title bar etc.).
- Which components are available within each toolbar and tool window, how they are arranged, their additional settings and shortcuts.
- What size is used for the interface components (icons, gadgets, tools etc.).

The complete customization – called the **configuration** – can be built, named and saved for future use. There are three pre-defined configurations in Natural Art corresponding to three different levels of experience of the user:

- **Simple level**
- **Junior level**
- **Advanced level**

However, you can extend this list by building several configurations of your own.

To switch to another configuration:

1. Open the **Customize** dialogue box either by choosing the **View->Customize…** option or by pressing **Ctrl+Alt+Space**.
2. Make sure that its **Configurations** tab is displayed.
3. Select one of the configurations.
4. Click on the **Use** button.
Customizing Natural Art

Note that the three pre-defined configurations cannot be re-defined. If you customize any of them, you will not be allowed to save the current configuration using the same name. However, you will be allowed to save it as a user-defined configuration with a different name.

Note that you can modify the way in which Natural Art is launched. To do so, you can specify different command line parameters. These are strings that specify an EXE file together with optional parameters to be run to start an application. The command line for Natural Art contains the file name NaturalArt.EXE with the complete path (which specifies the root folder) and may contain none or any of these parameters:

- `/C:<configuration>` – launches Natural Art with the specified configuration.
- `/NoSplashScreen` – launches Natural Art without showing the splash screen.
- `/GoToEXEDir` – makes Natural Art look for the My Paintings folder in the same folder in which `NaturalArt.EXE` is located.
- `/XM` – launches Natural Art in a window that cannot be minimized.
- `<file name> <file name> …` – launches Natural Art and immediately opens the specified files.

For example:

```
NaturalArt.EXE /C:"3. Advanced.CFG" /NoSplashScreen "My Paintings\picture.RNA"
```
6.1 Simple level

This is a simplified version (i.e. an introductory customization) of the Natural Art editor. It is suitable for young beginners. It can be used for creating pictures and paintings using free-hand drawing, painting, adding shapes and adding stamps. Note that it is only possible to work with one simple picture (of any supported file format) at this level of Natural Art.

The simple level of Natural Art offers:

- A restricted main menu offering the following options:
  - File with the basic operations.
  - Edit with the Undo and Redo options.
  - View with the Stamp Browser button, Other->Customize… option and Paper Properties… option.
  - Paint with three submenus: Brush, Shape and Stamp plus the Clear Picture option:
    - The Brush menu offers three types of brushes (see below).
    - The Shape menu offers Continuous Curve Freehand Drawing, Single Line, Outline of an Ellipse/Circle, Filled Ellipse/Circle, Outline of a Rectangle/Square, Filled Rectangle/Square, Outline of a Regular Polygon, Filled Regular Polygon, Outline of a Star, Filled Star and Continuous Fill.
    - The Stamp menu contains the Random Spacing and Shuffle options.
  - Help with Help Topics, Natural Art, Go to Latest Info… and About… options.
  - A reduced Main toolbar of basic picture operations (Open, Save and Print), Clear Picture, Paper Properties, Undo and Redo, a set of useful shapes, Fill and the Stamp Browser button.
Customizing Natural Art

- A reduced **Brush** toolbar with three types of brushes: **felt brush**, **colour tubs** and **wax crayon** (click on the arrows or the grey brush to choose another type of brush). Each type is available with a set of the most useful colours. You can select the colour by clicking it in the toolbar.

- A **Stamp Browser** with categories of stamps to be added into your pictures. You can either select a stamp, click on it then click on your paper, or click on a stamp then draw with it on your paper.

The simple level of Natural Art does not allow you to work with **stacks of pictures** (animations). To learn more about Natural Art, see its **junior level** or **advanced level**. To learn all about it, see the sections on:

- Welcome to Natural Art
- Exploring the workspace
- Creating and organizing pictures
- Working with a single picture
- Working with images: animations
- Customizing Natural Art
6.2 Junior level

This is recommended for users who have already become familiar with the simple level of Natural Art and want to be given more opportunities, more tools and more options for creating their pictures. Junior level is an extended customization of the Natural Art editor, which gives you all the features of the simple level and the following extensions:

- **Edit** menu gives you all possible options for working with selections (like Cut, Copy and Paste).
- **View** menu allows you to show/hide more toolbars and tool windows. It also allows you to choose one of three colour models and Zoom in or Zoom out.
- **Paint** menu adds an option for turning anti-aliasing and symmetry on/off.
  - The **Brush** submenu offers you the complete set of Natural Art brushes.
  - The **Shapes** submenu gives you all possible options.
  - You can also work fully with selections.
- **Main** toolbar is extended to include all Clipboard operations, all symmetry settings, the Colour Picker, the Selection button and the Toggle Zoom button.
- **Shapes** toolbar is extended to include all shapes.
- **Brushes** toolbar offers you the complete set of Natural Art brushes.
- **Palette** toolbar is available.
Neither the simple level nor junior level of Natural Art allow you to work with stacks of pictures (animations). To learn more about Natural Art, see its advanced level. To learn all about it, see the sections on:

- Welcome to Natural Art
- Exploring the workspace
- Creating and organizing pictures
- Working with a single picture
- Working with images: animations
- Customizing Natural Art
6.3 Advanced level

This is recommended for experienced users. All the menu options are available and so are all the standard **toolbars** and **tool windows**. This reference manual covers the advanced level. To learn all about it, see the sections on:

- **Exploring the workspace**
- **Creating and organizing pictures**
- **Working with a single picture**
- **Working with images: animations**
- **Customizing Natural Art**

Even for advanced users, however, it is worth developing specialized configurations with additional toolbars and tool windows, with alternative arrangements etc. to make the working environment more convenient, efficient and focused.
6.4 Setting up your own configuration: Customize dialogue box

Use this dialogue box to switch to another configuration or to inspect and/or build your own one.

To open this dialogue box:

1. Choose the **View->Other ->Customize…** option or press **Ctrl+Alt+Space**.

   The **Customize** dialogue box opens and Natural Art switches into **Customization** mode.

Now you cannot use the tools for drawing or painting and you cannot run options from the **main** menu. However, you can:

- Specify which menu options are provided to the user.
- Relocate each toolbar and tool window within the screen; delete it or create a new one.
- Inspect and/or modify the properties of toolbars and tool windows.
- Rearrange or modify the components that are displayed on the toolbars and tool windows.
- Set the size of icons and other additional settings.

(Note that even when Natural Art is not in **Customization** mode, you can move all the toolbars and tool windows within the screen, dock them or make them float – unless they are **locked** against it.)
The **Customize** dialogue box has five tabs:

- **Configurations**
- **Commands**
- **Components**
- **Bars and Windows**
- **Other**

**Configurations**

When you open this tab, you see the list of all currently available configurations, for example:

1. Simple
2. Junior
3. Advanced
   - My pencils
   - My charcoals

The first three are predefined configurations **Simple**, **Junior** and **Advanced**, which can be selected and used but cannot be modified or removed. All other listed configurations – if there are any – are **user-defined configurations** with the contents and names specified earlier by the user.

**Use**

To switch to another configuration:

1. Select its name in the list of configurations.
2. Click on the **Use** button.
3. Close the **Customize** dialogue box.
**Save**

Imagine you have just customized the environment of Natural Art in a way that suits the purpose you are using it for and you want to preserve this customization for future work as one of several alternative setups:

1. Click on the **Save** button.
2. Enter a name to your new **user-defined configuration**.

Note that you cannot use the name of any predefined configuration (Simple, Junior or Advanced).

Note that if you have just customized the environment of Natural Art and you close the **Customize** dialogue box without saving it as a new configuration, your most recent customization will be functional even after closing and re-opening Natural Art. However, if you continue the process of customization, your previous state of the environment will be lost and you will have no other way to return to it other than by re-building it again.

**Remove**

If you select a predefined configuration, the **Remove** button is automatically disabled, which means that you cannot remove it. If you want to remove a user-defined configuration:

1. Select it.
2. Click on the **Remove** button.

You will be prompted to confirm your decision.

Use this option carefully.

**Commands**

Use this tab to select which menu options are to be available in the configuration that you are building. Note that you cannot move an option from one menu to another or rearrange the order of options within one menu. However, you can hide an option from a menu or you can hide a whole submenu from a menu. The complete set of menu options can be found in the **advanced configuration**.
To customize menu option arrangements:

1. Open the **Commands** tab of the **Customize** dialogue box and inspect the current arrangement.

2. Seven options of the **main** menu are listed here, **File**, **Edit**, **View**, **Paint**, **Animation**, **Help** and **Other**. A + mark appears by each of them, and also by any option which opens a submenu of options. Click on it to see all the submenu options.

3. If a dark tick appears by an option, it is currently available (together with all of its nested options, if it has any). If you click on the dark tick, you will completely hide the option from the configuration (with all of its nested options). If a shaded tick appears by it, some of its nested options are not currently available, others are. Inspect the whole structure of menu options and tick or clear the marks.

4. If you select any option that does not open a submenu, the information about its shortcut or shortcuts – if it has any – appears in the small **Shortcuts** window. To create a shortcut associated with the option, click on the **Add** button and specify the shortcut. To remove a shortcut select the shortcut and click on the **Remove** button. If you specify a shortcut already associated with another option, you will get a warning message.

All options can be hidden except the **Customize…** one – so it is never possible to lose the way back to the **Customize** dialogue box. The default alternative option, to open it at any time, is the keyboard shortcut **Ctrl+Alt+Space**.
Components

Use this tab to arrange components within existing toolbars and tool windows. Note that components are icons, small graphical objects like the zoom box or text box, control elements like the drop down menu of all available fonts, the Stamp Browser etc. and other marks with special meanings.

All components available in Natural Art are organized into six groups (mainly corresponding to the options of the main menu) – File, Edit, View, Paint, Animation and Other, plus four special elements: Label, Horizontal Separator, Vertical Separator and Empty Space.

A + mark appears by each main group of components, and also by any of its subgroups. Click on it to see all the subgroups and components belonging to each group. To find a component, browse the structure. For example, if you are looking for a drop down menu with all available fonts, go into Paint->Shape->Text->Font – it is listed here together with all other components related to setting a font.

When you select a group and a component within it, for example Paint -> Brush Preset -> Cromar, its visual representation is displayed in the right part of the Components tab, sometimes accompanied by additional settings like the default colour setting or the default nib size etc.
Adding a component

To add a component to a toolbar or a tool window:

1. Browse the Components structure to find it.
2. If it is accompanied by an additional setting or settings, specify their values and drag the visual representation of the component (its icon) to the target toolbar or tool window.
3. Locate the icon there and specify its location properties, see below.

Deleting a component

Whenever you turn on Customization mode you can click on any component on any toolbar or tool window and drag it away from its position. You can either place it anywhere else on its original or another toolbar or tool window or you can drag it into the working area and release the button there, in which case the component is deleted.
Location properties of a component

Whenever you turn on Customization mode you can right-click on any component on any toolbar or tool window. A menu belonging to that component opens.

The first group of options in the menu specify the way in which the component is located and resized horizontally. The second group of options specify the way in which the component is located and resized vertically.

Bars and Windows

Use this tab to create or delete toolbars and tool windows and to modify their properties. In its left part there is a list of the names of all currently existing toolbars and tool windows (you can distinguish them by their slightly different icons). In the right part of the tab there are four buttons: New Toolbar, New Tool Window, Delete and Properties.…

New Toolbar

If you click on this button, a new, empty toolbar is created. You can now specify its properties (see below), then go to the Components tab and add components to it. Note that the size of the toolbar is always decided by Natural Art itself and cannot be changed. It depends on the sizes and types of its components and on the properties, settings and current position of the toolbar.

Note that each new toolbar you create gets a default name (like Bar 3) and immediately appears in the list of toolbars and tool windows. It also appears as an item in the View->Bars and Windows submenu, this gives you the option of showing or hiding the toolbar.
If you want to give it another name (for example, My pencils), go into its **Properties**.

![Image](image.png)

**New Tool Window**

If you click on this button, a new empty **tool window** will be created. You can now specify its properties (see below), then go to the **Components** tab and add components to it. Note that you can resize the tool window and also specify its position. The size and position of each tool window is one of the settings saved within a configuration.

Note that each new tool window you create gets a default name (e.g. Window 2) and immediately appears in the list of all toolbars and tool windows. It also appears as an item in the **View->Bars and Windows** submenu, this gives you the option of showing or hiding the tool window. If you want to give it another name (for example, My tools), go into its **Properties**.

**Delete**

If you want to delete any toolbar or tool window from the current configuration, click on its name in the list of all toolbars and tool windows, then click on the **Delete** button. Note that this is completely different from hiding the toolbar or tool window. If you delete a toolbar or tool window, it does not exist any more and it will not appear in the **View->Bars and Windows** submenu. This allows you to delete any toolbar or tool window from the current configuration, even very basic ones.
Properties

Use this button to inspect or modify the properties of any toolbars or tool windows. Click on the name of the toolbar or tool window that you want to modify, then click on the Properties button. The Toolbar Properties dialogue box opens with the following settings:

Title, its position and how it is displayed.

Here you can see or modify the toolbar's or tool window's title. You can specify whether the title should be displayed on its Left side, Top side, Right side or Bottom side.

You can also specify whether the title should be displayed when the toolbar or tool window is floating and when the tool bar is docked.
**Layout Horizontal** or **Vertical**

Each toolbar and tool window must be declared as being either **Horizontal** or **Vertical**. If it is horizontal you will only be allowed to dock it to the top or bottom borders of the main window. If it is vertical you will only be allowed to dock it to the left or right borders of the main window.

**Size**

For each tool window you can specify whether the user is allowed to change its width or height. You can also specify whether the window should expand to its maximum width when it is docked to one of the borders of the main window.

If you explore the properties of a toolbar, you will find that all three settings concerning the size of the toolbar are disabled. The reason is that the size of each toolbar is decided automatically by Natural Art itself and cannot be modified by the user.

**Visibility**

If you select this option, the toolbar or tool window will be shown. If you clear it, the toolbar or tool window will be hidden. In spite of this setting, the user may choose the View->Bars and Windows option and select or clear the name of the toolbar or tool window even when not in Customization mode.

**Behaviour**

This drop down menu contains eight options. The first one, **Standard Bar or Window**, is the default behaviour for most standard or user-created toolbars and tool windows. However, seven standard toolbars and tool windows (**Brushes, Motifs, Organizer, Palette, Paper Textures, Stamps** and **Text**) have predefined (special) behaviours. So, for example, the **Brushes** toolbar has the **Brushes** value set here. If you create your own toolbar or tool window and you want it to be treated like the **Brushes** toolbar, set the **Brushes** value here as its behaviour. Do the same for any user-created toolbar or tool window if you want it to be treated like any of these seven standard toolbars and tool windows.
Locked

Each toolbar or tool window can be protected by this setting against unintentional modifications. A locked toolbar or window cannot be moved, resized, docked (if it is floating) or made floating (if it is docked).

Other

Use this tab to specify some additional settings.

Edit one picture only

This option is recommended for beginners only (it is used in simple level and junior level). If you select it, the user will not be allowed to open or create more than one picture in parallel. This means that the Organizer contains only one item (and thus is usually not allowed in a customization that makes use of the Edit one picture only option).

If you clear this option, the user will be allowed to work with several pictures in parallel, see the section on Working with several pictures.
Stamps folder

This option allows you to open the Browse for Folder dialogue box and specify the root folder for the Stamp Browser. To do so, click on the … button. To restore the default value, click on the X button in the Stamps folder line.

This piece of information may be different for different configurations. Whenever you open the Stamp Browser, the current contents of the specified folder is displayed and its category drop down menu lists the names of all subfolders of the root folder.

Icons size

You can specify the appropriate size of icons within all toolbars and tool windows. Note that you cannot resize individual icons, this setting is global and common to all icons. For more advanced users the recommended size is about 33%, for younger users it may be appropriate to use 50% or more.
Skin

You can specify an alternative visual style or 'skin' for the background of the main window and all toolbars and tool windows. To do so, open the Open dialogue box by clicking on the ... button in the Skin line. In this dialogue box you can either select an alternative skin in the Skins subfolder of Natural Art, or browse through other folders to look for any device independent bitmap *.DIB or windows bitmap *.BMP file. To restore the default skin, click on the X button in the Skin line.
closed polygon  See splines and polygons.

closed spline  See splines and polygons.

frame  A building block of an image in the Revelation Natural Art Organizer. Frames usually illustrate a character in different directions (like walking to the right, walking towards us, walking to the left and walking away from us).

Here the circle of all possible headings has been divided into four different sections (i.e. it is represented by four different frames).
However, the number of such sections (frames) is not limited.

Each frame may be a single picture, or a stack of pictures called frame items. There is no restriction on the maximum size of a frame (other than the restriction of the Windows graphics resources).

frame item

Each frame of an image may either be a single picture or a stack of pictures called frame items. If a frame consists of several frame items and you use that image in Imagine as a shape of a turtle, the frame items are automatically cycled through, so that the illusion of a screen animation is created automatically.

Natural Art provides you with a powerful environment for creating and exploring such animated stacks of frame items. You can develop and explore these stacks in Preview mode.

Note that when animating a stack of frame items, the attached time delays are used.

image

Images are complex graphical data objects of Imagine that are used mainly as the shapes of turtles. Natural Art provides you with a powerful environment for creating and exploring them.

Each image is an empty or non empty series of frames. Each frame is either a single picture or a stack of pictures – a kind of animation film that illustrates, for example, the movement of a character in a particular direction. Thus, different frames may illustrate the movement of the same character in different directions (like walking to the right, walking towards us, walking to the left and walking away from us).
Images are stored in **RNA files** (or the older **LGF files** of Imagine or **LGW files** of SuperLogo). In addition to its own graphical contents, each image has additional information attached to it:

- **Time delay** for each frame item.
- **HotSpot** for each frame item.
- **Style**: **Heading mode or Frame mode**.
- **Zero angle**.
- **Animation loop** (yes or no).

**Imagine**
Imagine is a new generation of the Logo language environment published by Logotron. It has been developed for students who want to perform a broad range of activities like painting and animating, Web authoring, 'traditional' Logo, creating multimedia applications, using speech input and output, modelling, constructing domain-specific learning frameworks, communicating ideas, building presentations, developing projects and microworlds for numeracy, literacy or science, working with data etc. Imagine has an object-oriented structure merged into the traditional Logo. It supports a hierarchy of objects and behaviours, parallel independent processes, direct painting tools, an extended direct manipulation interface and other characteristics. The ultimate goal of Imagine is to provide students, teachers and developers with a challenging general tool for learning.

Some of the most interesting features of Imagine are:

- Turtles and turtle geometry.
- Single and multiple turtles.
- Choosers and other visual gadgets.
- Events and parallel processes.
- Object-oriented structure with primitive and user-defined classes.
Glossary of basic terms and concepts

- Non-turtle drawing tools.
- Multimedia and voice input/output.
- Direct manipulations and a rich environment.

**LGF file**  The native file type of Imagine for storing **images**.

**LGW file**  The native file type of SuperLogo (the predecessor to Imagine) and MegaPaint for storing **images**. SuperLogo images and **LGW** files are still recognised and accepted by Imagine. Generalised images of Imagine are stored in **LGF** files.

**LogoMotion**  LogoMotion – the predecessor to Natural Art – is a powerful bitmap and animation editor. Working with Imagine, LogoMotion lets you create or modify **images**, which may be used as the shapes of turtles. In addition, LogoMotion allows you to create and/or modify Windows bitmaps to be used as background pictures in Imagine or completely outside of the Imagine environment.

LogoMotion provides an excellent range of tools for drawing and painting, writing text and inserting basic regular geometric shapes.

It can also be used to develop or modify standard Windows icons and cursors, and it works with the standard Windows Clipboard. LogoMotion makes it possible to resize, rotate and colour images. It also provides powerful tools for generating and/or transforming animations or animated films, i.e. sequences of **frame items**. It supports many other advanced graphics operations.

**motif**  A motif is a small graphical element used repeatedly instead of a colour to fill polygons, rectangles or whole continuous regions. Motifs are stored as device independent bitmaps *.*DIB in the **Motifs** subfolder of Natural Art.
| **polygon** | See [splines and polygons](#). |
| **RNA file** | The native Revelation Natural Art image file. RNA files contain one or several (compressed) images. |
| **splines and polygons** | Polygons are sequences of connected line segments. Splines are smooth curves connecting several points. |

Both polygons and splines can be either **simple**, **closed** or **filled**.

| **supported file format** | These are the file formats supported for **File->Open** by Natural Art: |
| | • Revelation Natural Art Image File *.*RNA |
| | • LogoMotion and Imagine Image File *.*LGF |
| | • Imagine Project File *.*IMP |
| | • SuperLogo Image File *.*LGW |
Glossary of basic terms and concepts

- Windows Bitmap *.BMP
- Device Independent Bitmap *.DIB
- Joint Photographic Experts Group *.JPG
- CompuServe Bitmap *.GIF
- Animated Cursor *.ANI
- Cursor *.CUR
- Icon *.ICO
- Windows Metafile *.WMF and *.EMF
- Targa *.TGA
- Portable Network Graphics *.PNG

These are the file formats supported for File->Save As by Natural Art:

- Revelation Natural Art Image File *.RNA
- LogoMotion and Imagine Image File *.LGF
- Windows Bitmap *.BMP
- Device Independent Bitmap 32bpp *.DIB
- Joint Photographic Experts Group *.JPG
- Animated Cursor *.ANI
- Cursor *.CUR
- Icon *.ICO
- CompuServe Bitmap *.GIF
- Targa *.TGA
- Portable Network Graphics *.PNG
**toolbar**  A toolbar is a narrow horizontal or vertical strip with one row or one column of icons and other control components. It is either:

- **Docked** to one of the margins of the Natural Art main window, or
- **Docked** to another docked toolbar, or
- **Floating** on the screen.

**tool window**  A tool window is similar to a toolbar, however you can resize it to any size and you can arrange components on the tool window in any way, for example in two columns etc.
8 Table of keyboard shortcuts

This is a list of all standard (default) keyboard shortcuts to menu options and buttons. Note that you can customize the keyboard shortcuts. Note also that some options have more than one default shortcut combination. For example, if you press Ctrl+O or F3, the File->Open… option will be run.

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Menu option</th>
<th>Button in a toolbar or tool window</th>
</tr>
</thead>
<tbody>
<tr>
<td>[</td>
<td>Paint-&gt;Selection-&gt;Transform-&gt;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Rotate by 270°</td>
<td></td>
</tr>
<tr>
<td>]</td>
<td>Paint-&gt;Selection-&gt;Transform-&gt;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Rotate by 90°</td>
<td></td>
</tr>
<tr>
<td>Alt+BackSpace</td>
<td>Edit-&gt;Undo &lt;last change&gt;</td>
<td>Main toolbar-&gt;Undo</td>
</tr>
<tr>
<td>Alt+F2</td>
<td>File-&gt;Save As…</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Paint-&gt;Selection-&gt;Save</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Selection As…</td>
<td></td>
</tr>
<tr>
<td>Alt+F3</td>
<td>File-&gt;Close</td>
<td></td>
</tr>
<tr>
<td>Alt+F7</td>
<td>View-&gt;Other-&gt;Colour Chooser</td>
<td></td>
</tr>
<tr>
<td>Alt+G</td>
<td>Animation-&gt;Generate…</td>
<td></td>
</tr>
<tr>
<td>Alt+T</td>
<td>Animation-&gt;Transform…</td>
<td></td>
</tr>
<tr>
<td>Alt+X</td>
<td>File-&gt;Exit</td>
<td></td>
</tr>
</tbody>
</table>
## Table of keyboard shortcuts

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Menu option</th>
<th>Button in a toolbar or tool window</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+`</td>
<td>Paint-&gt;Selection-&gt;Transparent</td>
<td></td>
</tr>
<tr>
<td>Ctrl+A</td>
<td>Edit-&gt;Select All</td>
<td></td>
</tr>
<tr>
<td>Ctrl+Alt+Space</td>
<td>View-&gt;Other-&gt;Customize…</td>
<td></td>
</tr>
<tr>
<td>Ctrl+B</td>
<td>Animation-&gt;Blend</td>
<td></td>
</tr>
<tr>
<td>Ctrl+C</td>
<td>Edit-&gt;Copy</td>
<td>Main toolbar-&gt;Copy</td>
</tr>
<tr>
<td>Ctrl+D</td>
<td>Animation-&gt;Set Delay…</td>
<td></td>
</tr>
<tr>
<td>Ctrl+F4</td>
<td>File-&gt;Close</td>
<td></td>
</tr>
<tr>
<td>Ctrl+F7</td>
<td>View-&gt;Other-&gt;Colour Settings</td>
<td></td>
</tr>
<tr>
<td>Ctrl+H</td>
<td>Animation-&gt;Set HotSpot…</td>
<td></td>
</tr>
<tr>
<td>Ctrl+Insert</td>
<td>Edit-&gt;Copy</td>
<td>Main toolbar-&gt;Copy</td>
</tr>
<tr>
<td>Ctrl+M</td>
<td>Animation-&gt;Minimize</td>
<td>Animation toolbar-&gt;Minimize Picture</td>
</tr>
<tr>
<td>Ctrl+N</td>
<td>File-&gt;New</td>
<td></td>
</tr>
<tr>
<td>Ctrl+Num -</td>
<td>View-&gt;Zoom-&gt;Zoom Out</td>
<td></td>
</tr>
<tr>
<td>Ctrl+Num *</td>
<td>View-&gt;Zoom-&gt;Normal Size</td>
<td></td>
</tr>
<tr>
<td>Ctrl+Num +</td>
<td>View-&gt;Zoom-&gt;Zoom In</td>
<td></td>
</tr>
<tr>
<td>Ctrl+O</td>
<td>File-&gt;Open…</td>
<td>Main toolbar-&gt;Open</td>
</tr>
<tr>
<td>Ctrl+P</td>
<td>File-&gt;Print…</td>
<td>Main toolbar-&gt;Print…</td>
</tr>
</tbody>
</table>
### Table of keyboard shortcuts

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Menu option</th>
<th>Button in a toolbar or tool window</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Q</td>
<td>View-&gt;Zoom-&gt;Zoom Out</td>
<td></td>
</tr>
<tr>
<td>Ctrl+R</td>
<td>Animation-&gt;Reverse Order</td>
<td></td>
</tr>
<tr>
<td>Ctrl+S</td>
<td>File-&gt;Save</td>
<td>Main toolbar-&gt;Save</td>
</tr>
<tr>
<td>Ctrl+V</td>
<td>Edit-&gt;Paste or Edit-&gt;Paste After</td>
<td>Main toolbar-&gt;Paste</td>
</tr>
<tr>
<td>Ctrl+W</td>
<td>View-&gt;Zoom-&gt;Zoom In</td>
<td></td>
</tr>
<tr>
<td>Ctrl+X</td>
<td>Edit-&gt;Cut</td>
<td>Main toolbar-&gt;Cut</td>
</tr>
<tr>
<td>Ctrl+Z</td>
<td>Edit-&gt;Undo &lt;last change&gt;</td>
<td>Main toolbar-&gt;Undo</td>
</tr>
<tr>
<td>Del</td>
<td>Edit-&gt;Delete</td>
<td></td>
</tr>
<tr>
<td>F1</td>
<td>Help-&gt;Natural Art</td>
<td></td>
</tr>
<tr>
<td>F11</td>
<td>View-&gt;Stamp Browser</td>
<td>Main toolbar-&gt;Stamp Browser</td>
</tr>
<tr>
<td>F2</td>
<td>File-&gt;Save</td>
<td></td>
</tr>
<tr>
<td>F3</td>
<td>File-&gt;Open…</td>
<td></td>
</tr>
<tr>
<td>F4</td>
<td>View-&gt;Organizer</td>
<td></td>
</tr>
<tr>
<td>F5</td>
<td>View-&gt;Brushes</td>
<td></td>
</tr>
<tr>
<td>F7</td>
<td>View-&gt;Palette</td>
<td></td>
</tr>
<tr>
<td>F8</td>
<td>View-&gt;Zoom Settings</td>
<td></td>
</tr>
<tr>
<td>Shortcut</td>
<td>Menu option</td>
<td>Button in a toolbar or tool window</td>
</tr>
<tr>
<td>-----------</td>
<td>------------------------------</td>
<td>---------------------------------------------</td>
</tr>
<tr>
<td><strong>F9</strong></td>
<td>View-&gt;Preview</td>
<td></td>
</tr>
<tr>
<td><strong>Ins</strong></td>
<td>Edit-&gt;Insert After</td>
<td></td>
</tr>
<tr>
<td>Shift+Ctrl+Z</td>
<td>Edit-&gt;Redo &lt;last change&gt;</td>
<td>Main toolbar-&gt;Redo</td>
</tr>
<tr>
<td>Shift+Ctrl+Z</td>
<td>Edit-&gt;Undo &lt;last change&gt;</td>
<td></td>
</tr>
<tr>
<td>Shift+Delete</td>
<td>Edit-&gt;Cut</td>
<td>Main toolbar-&gt;Cut</td>
</tr>
<tr>
<td>Shift+Insert</td>
<td>Edit-&gt;Paste or Edit-&gt;Paste</td>
<td>Main toolbar-&gt;Paste</td>
</tr>
<tr>
<td></td>
<td>After</td>
<td></td>
</tr>
<tr>
<td><strong>X</strong></td>
<td></td>
<td>Animation toolbar-&gt;Go to Next Frame Item</td>
</tr>
<tr>
<td><strong>Z</strong></td>
<td></td>
<td>Animation toolbar-&gt;Go to Previous Frame Item</td>
</tr>
</tbody>
</table>